Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69782 - [python-pyadi-iio] conflict files with python-litex-boards

Attached to Project: Community Packages
Opened by Michal Wojdyla (micwoj92) - Thursday, 25 February 2021, 18:35 GMT
Last edited by Filipe Laíns (FFY00) - Saturday, 13 March 2021, 15:18 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Filipe Laíns (FFY00)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Can't install both packages due to conflicting files


Additional info:
* package version(s) 0.0.4-2

Steps to reproduce:
1. sudo pacman -S python-litex-boards python-pyadi-iio
2. error: failed to commit transaction (conflicting files)
/usr/lib/python3.9/site-packages/test/__init__.py exists in both 'python-litex-boards' and 'python-pyadi-iio'
/usr/lib/python3.9/site-packages/test/__pycache__/__init__.cpython-39.opt-1.pyc exists in both 'python-litex-boards' and 'python-pyadi-iio'
/usr/lib/python3.9/site-packages/test/__pycache__/__init__.cpython-39.pyc exists in both 'python-litex-boards' and 'python-pyadi-iio'
Errors occurred, no packages were upgraded.

This task depends upon

Closed by  Filipe Laíns (FFY00)
Saturday, 13 March 2021, 15:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-pyadi-iio 0.0.4-3
python-litex-boards 2020.12-2
Comment by loqs (loqs) - Thursday, 25 February 2021, 18:39 GMT
No package should be shipping /usr/lib/python3.9/site-packages/test/ [1]

pacman -F /usr/lib/python3.9/site-packages/test/
usr/lib/python3.9/site-packages/test/ is owned by community/python-augeas 1.1.0-3
usr/lib/python3.9/site-packages/test/ is owned by community/python-litex-boards 2020.12-1
usr/lib/python3.9/site-packages/test/ is owned by community/python-pyadi-iio 0.0.4-2

[1] https://archlinux.org/todo/python-modules-including-site-packagestests/
Comment by Michal Wojdyla (micwoj92) - Thursday, 25 February 2021, 18:58 GMT
@loqs in linked todo the list is complete, should more such errors be reported?
Comment by Michal Wojdyla (micwoj92) - Sunday, 28 February 2021, 22:18 GMT
edit: nvm, i didnt read your comment properly
Comment by loqs (loqs) - Sunday, 28 February 2021, 22:40 GMT
@micwoj92 please try applying the attached diffs to the appropriate PKGBUILDs. Does that resolve the issue?
Edit:
Corrected name, apologies.
Comment by Michal Wojdyla (micwoj92) - Sunday, 28 February 2021, 23:02 GMT
It's micwoj92, Actually I am now getting error in check in python-pyadi-iio, is it because I am not building in chroot?
Comment by Michal Wojdyla (micwoj92) - Sunday, 28 February 2021, 23:10 GMT
I built and installed other packages and I could install them, so it is working.

Loading...