Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#6978 - snd-hda-intel not working in 2.6.20.7

Attached to Project: Arch Linux
Opened by Cristian Gimenez (kastor) - Sunday, 22 April 2007, 21:15 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 05 May 2007, 15:51 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity High
Priority Normal
Reported Version 0.8 Voodoo
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The module loads but the soundcard is not detected with kernel26 2.6.20.7-2 (i think that is something like: http://bugs.archlinux.org/task/6617

This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 05 May 2007, 15:51 GMT
Reason for closing:  Fixed
Comment by Cristian Gimenez (kastor) - Monday, 23 April 2007, 17:30 GMT
i tried with your http://www.archlinux.org/~tpowa/2.6.21/ and nothing happens.. module is loaded but no sound device /dev/dsp exists..
Comment by Cristian Gimenez (kastor) - Monday, 23 April 2007, 18:35 GMT
i tried with your http://www.archlinux.org/~tpowa/2.6.21/ and nothing happens.. module is loaded but no sound device /dev/dsp exists..
Comment by Roman Kyrylych (Romashka) - Wednesday, 25 April 2007, 17:30 GMT
As per "2.6.21-rc7: known regressions (v2)": http://lkml.org/lkml/2007/4/23/291
snd_hda_intel doesn't work with ASUS M2V mainboard
http://bugzilla.kernel.org/show_bug.cgi?id=8273
Comment by Nicola (drakkan) - Saturday, 28 April 2007, 09:23 GMT
I have a similar problem, this is my audio card:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
Subsystem: Toshiba America Info Systems Unknown device ff10
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 22
Region 0: Memory at f0c00000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Address: 0000000000000000 Data: 0000
Capabilities: [70] Express Unknown type IRQ 0
Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
Device: Latency L0s <64ns, L1 <1us
Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
Link: Supported Speed unknown, Width x0, ASPM unknown, Port 0
Link: Latency L0s <64ns, L1 <1us
Link: ASPM Disabled CommClk- ExtSynch-
Link: Speed unknown, Width x0

my problem seems similar to this:

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/107821

for windows toshiba release realtek audio drivers so maybe the realtek patch can solve this,

thanks
Comment by Tobias Powalowski (tpowa) - Sunday, 29 April 2007, 06:33 GMT
status on .21 kernel? it contains the latest alsa hg snapshot from 070427
Comment by Nicola (drakkan) - Sunday, 29 April 2007, 09:54 GMT
same on .21 kernel, I installed the following package from testing:

alsa-lib-1.0.14rc3-2 alsa-utils-1.0.14rc2-2 ipw3945-1.2.0-6 kernel26-2.6.21.1-5 madwifi-0.9.3-4 nvidia-1.0.9755-5 slmodem-2.9.11-25

and still no sounds, additionally I have only a PCM channel no MASTER

on ubuntu the sounds works, can you grab the patch from there?

additional info:

uname -a
Linux a100-881 2.6.21-ARCH #1 SMP PREEMPT Sat Apr 28 10:43:58 CEST 2007 i686 Intel(R) Core(TM)2 CPU T7600 @ 2.33GHz GenuineIntel GNU/Linux
[root@a100-881 nicola]# pacman -Qs alsa
local/alsa-lib 1.0.14rc3-2
An alternative implementation of Linux sound support
local/alsa-oss 1.0.12-1
OSS compatibility library
local/alsa-utils 1.0.14rc2-2
An alternative implementation of Linux sound support
local/gstreamer0.10-alsa 0.10.12-1
GStreamer alsa plugin
[root@a100-881 nicola]# lsmod | grep '^snd'
snd_seq_oss 29184 0
snd_seq_midi_event 6528 1 snd_seq_oss
snd_seq 46928 4 snd_seq_oss,snd_seq_midi_event
snd_seq_device 6796 2 snd_seq_oss,snd_seq
snd_pcm_oss 39072 0
snd_mixer_oss 14464 1 snd_pcm_oss
snd_hda_intel 232984 1
snd_pcm 68996 2 snd_pcm_oss,snd_hda_intel
snd_timer 19204 2 snd_seq,snd_pcm
snd 43876 10 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_pcm,snd_timer
snd_page_alloc 7944 2 snd_hda_intel,snd_pcm
[root@a100-881 nicola]# ls -l /dev/sn
snapshot snd/
[root@a100-881 nicola]# ls -l /dev/snd/
totale 0
crw-rw---- 1 root audio 116, 0 29 apr 2007 controlC0
crw-rw---- 1 root audio 116, 24 29 apr 2007 pcmC0D0c
crw-rw---- 1 root audio 116, 16 29 apr 2007 pcmC0D0p
crw-rw---- 1 root audio 116, 30 29 apr 2007 pcmC0D6c
crw-rw---- 1 root audio 116, 22 29 apr 2007 pcmC0D6p
crw-rw---- 1 root audio 116, 1 29 apr 2007 seq
crw-rw---- 1 root audio 116, 33 29 apr 2007 timer
[root@a100-881 nicola]# id nicola
uid=1000(nicola) gid=1000(nicola) gruppi=1000(nicola),5(tty),6(disk),10(wheel),90(network),91(video),92(audio),93(optical),95(storage),98(power),97(camera),96(scanner)
[root@a100-881 nicola]# amixer set Master 90% unmute
amixer: Unable to find simple control 'Master',0

[root@a100-881 nicola]# amixer set PCM 90% unmute
Simple mixer control 'PCM',0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 230 [90%] [-5.00dB]
Front Right: Playback 230 [90%] [-5.00dB]
Comment by Nicola (drakkan) - Sunday, 29 April 2007, 10:18 GMT
Solution found, for my card I have to add the following to modprobe.conf

options snd-hda-intel model=3stack

If you need additional info ask me,

thanks
Nicola
Comment by Tobias Powalowski (tpowa) - Sunday, 29 April 2007, 10:23 GMT
could you others please also confirm this fix?
Comment by Cristian Gimenez (kastor) - Monday, 30 April 2007, 12:55 GMT
works for me with the lastest stock kernel thanx a lot
Comment by Scott H (stonecrest) - Tuesday, 01 May 2007, 04:33 GMT
Awesome, that fix worked here too.
Comment by Roman Kyrylych (Romashka) - Tuesday, 01 May 2007, 11:11 GMT
OK, so this report can be closed, I think.
But we should made users aware of that workaround.
I propose the following: in kernel's post_install add that line (commented, of course) to modprobe.conf, in the same way as this is done to ld.so.conf.
Comment by Tobias Powalowski (tpowa) - Saturday, 05 May 2007, 15:51 GMT
closing this now, its not worth modifying modprobe.conf its now mentioned on frontpage.
It's an error in autodetection of the module, which will hopefully fixed soon by alsa upstream

Loading...