Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#69778 - [linux] update to Linux 5.11.1 failed to boot, btrfs error

Attached to Project: Arch Linux
Opened by John Huang (john_huang) - Thursday, 25 February 2021, 08:53 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 25 February 2021, 15:58 GMT
Task Type Bug Report
Category Kernel
Status Assigned
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 3
Private No


update to Linux 5.11.1.arch1-1 failed to boot, but 5.10.18-1-lts is fine.

kernel message:
BTRFS error (device nvme0n1p2): device total_bytes should be at most 235954608640 but found 255954587648
BTRFS error (device nvme0n1p2): failed to read chunk tree: -22
BTRFS error (device nvme0n1p2): open_ctree failed.

But i run command "btrfs check /dev/nvme0n1p2", no error founded.

Additional info:
package version: linux-5.11.1.arch1-1 btrfs-progs-5.10.1-1

Steps to reproduce:
just power on my computer.
This task depends upon

Comment by ZephireNZ (ZephireNZ) - Friday, 26 February 2021, 06:26 GMT
I also experienced the same when upgrading to 5.11.1, and rolling back to 5.10.16 similarly also resolved the issue.

After googling, the fix was to rollback to 5.10 (I assume Live USB would also work), and run `btrfs filesystem resize max /path/to/mount`. This allowed me to upgrade to 5.11.1 without issues.
Comment by John Huang (john_huang) - Friday, 26 February 2021, 06:40 GMT
Thanks ZephireNZ.
After run `btrfs filesystem resize max /`, the kernel can boot up without error.
Comment by Nguyễn Duy Hùng (nodohoung) - Saturday, 27 February 2021, 03:20 GMT
I got same issue. Fixed by downgrading kernel to 5.10.16
Comment by Eduardo Castillo (arch-newbye) - Saturday, 27 February 2021, 22:36 GMT
Since I update to kernel 5.11, something strange has happened to me, it only happens when compressing a file, the core temperature rises to 80 ºC and it turns off automatically. Any idea if it's update problem?
Comment by Kevin (unhammer) - Tuesday, 16 March 2021, 09:30 GMT
Since this affects a lot of users, perhaps it warrants an email to arch-announce?

(For me as well, the solution was `sudo pacman -U /var/cache/pacman/pkg/linux*5.10*`, reboot and and `btrfs filesystem resize max /home`, then upgrading to 5.11 worked fine.)