Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69775 - [linux][xfwm4] Upgrade to linux 5.11 causes coredump

Attached to Project: Arch Linux
Opened by JM (justm3) - Thursday, 25 February 2021, 05:34 GMT
Last edited by Evangelos Foutras (foutrelis) - Friday, 19 March 2021, 05:55 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:Upgrade to 5.11.1 causes coredump


Additional info:
No joy with completely remove & reinstall
lts-5.10.18-1 working without issues.

Steps to reproduce:
1.Install linux 5.11.1
2.Reboot
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Friday, 19 March 2021, 05:55 GMT
Reason for closing:  No response
Comment by Christian Hesse (eworm) - Thursday, 25 February 2021, 07:04 GMT
This is completely unrelated to systemd, no?
Comment by JM (justm3) - Thursday, 25 February 2021, 07:24 GMT
This is how it is reported by the journal. I think you stand correct but I did not know how to report it otherwise.
Would you like to delete it and I could re-submit specific to xfwm? I'll be happy to do it if you wish.
Comment by Christian Hesse (eworm) - Thursday, 25 February 2021, 07:47 GMT
Updated the details and assigned to foutrelis for xfwm4.

BTW... using Xfce myself, I do not see this.
Comment by Evangelos Foutras (foutrelis) - Thursday, 25 February 2021, 09:43 GMT
Look for the actual XError message similar to  FS#69095  (the "BadWindow" line and the one after it). You might need to run startxfce4 from the command line to see the error, if it's not in the journal and/or ~/.xsession-errors.
Comment by JM (justm3) - Thursday, 25 February 2021, 12:02 GMT
I can't seem to locate it. Attached file .xsession=errors
Comment by Evangelos Foutras (foutrelis) - Thursday, 25 February 2021, 12:26 GMT
Your attached file seems to be using the 5.10 LTS kernel; retry with 5.11.
Comment by JM (justm3) - Thursday, 25 February 2021, 14:18 GMT
Very sorry for that, I forgot that it changes when I switched to the lts.
Attached again with 5.11.1
Comment by Evangelos Foutras (foutrelis) - Thursday, 25 February 2021, 16:58 GMT
Created an issue upstream: https://gitlab.xfce.org/xfce/xfwm4/-/issues/519

Feel free to post additional details such as GPU information there. Keep in mind that it will be hard to investigate if it's not producible for others.
Comment by Evangelos Foutras (foutrelis) - Sunday, 28 February 2021, 17:11 GMT
@justm3: Can you provide the backtrace requested by upstream? [1] You'll probably need an xfwm4 build with "options=('!strip')", then do something like "export GDK_SYNCHRONIZE=1; startxfce4" in a console and check if coredumpctl and/or journalctl show a backtrace with (xfwm4) symbols.

[1] https://gitlab.xfce.org/xfce/xfwm4/-/issues/519#note_26401
Comment by JM (justm3) - Sunday, 28 February 2021, 18:34 GMT
@foutrelis
Attached coredumpctl.
Will follow with journalctl
I did not rebuild xfwm4
Comment by JM (justm3) - Sunday, 28 February 2021, 18:34 GMT
@foutrelis
Attached journalctl

Let me know if these files suffice.
Comment by Evangelos Foutras (foutrelis) - Sunday, 28 February 2021, 18:37 GMT
You need to rebuild xfwm4 with "options=('!strip')" and post a backtrace with symbols to the upstream bug so I don't have to play messenger. :)

Also try something like "coredumpctl info" instead of just "coredumpctl" which doesn't show the backtrace.
Comment by JM (justm3) - Sunday, 28 February 2021, 18:43 GMT
@foutrelis
I am sorry to be a hassle. I was not aware of the procedure.
Take care and tks a mil.
Comment by Evangelos Foutras (foutrelis) - Tuesday, 02 March 2021, 09:35 GMT
Try this "options=(!strip debug)" build: https://pkgbuild.com/~foutrelis/xfwm4-fs69775/

Then, if you start Xfce from the console using "export GDK_SYNCHRONIZE=1; startxfce4", you should be able to get a backtrace with symbols (viewable with "coredumpctl info").
Comment by Evangelos Foutras (foutrelis) - Sunday, 07 March 2021, 11:33 GMT
Have you had a chance to test the above package to see if it produces a symbolized backtrace?

Loading...