Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69774 - Cheese is missing CSD headerbar in all non-GNOME DEs

Attached to Project: Arch Linux
Opened by Archisman Panigrahi (archisman) - Thursday, 25 February 2021, 04:23 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 10 October 2021, 19:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: Cheese Webcam Booth does not show headerbar in any non-GNOME DEs (XFCE, Cinnamon, KDE and probably many more). As a result, users cannot change webcam resolution, or select webcams when multiple webcams are connected.


Additional info:
* package version(s) 3.38.0-1
* link to upstream bug report https://gitlab.gnome.org/GNOME/cheese/-/issues/62

Steps to reproduce: Open cheese in either XFCE, Cinnamon or KDE. CSD Headerbar is missing.

A patch has been proposed upstream (https://gitlab.gnome.org/GNOME/cheese/-/merge_requests/34), but it seems that the GNOME developers are not interested in accepting the merge request. Ubuntu has already patched Cheese with this code (https://bugs.launchpad.net/ubuntu/+source/cheese/+bug/1879183).

I created an AUR (https://aur.archlinux.org/packages/cheese-csd-headerbar/) with the patch, but I was told that I should create a bug report with Arch Linux instead.

Please consider if the Arch Cheese package can be patched, because upstream is apparently not interested in it, while every major desktop environment (except GNOME) are affected.

I am choosing "Severity: High" because one of the main functionalities (choosing the webcam and changing the resolution) does not work.

I have tested that the patch does fix the issue in KDE, Cinnamon and XFCE, and someone reported in Launchpad that it does not cause any regression in GNOME (https://bugs.launchpad.net/ubuntu/+source/cheese/+bug/1879183/comments/20)
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 10 October 2021, 19:53 GMT
Reason for closing:  Fixed
Comment by Archisman Panigrahi (archisman) - Thursday, 23 September 2021, 07:01 GMT
This has been fixed upstream (the patch was merged), and the newly released cheese 41 does not have this issue.

Loading...