Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69729 - [xdotool] Gibberish Typing + Multiple HotKeys Executions on keyboard shortcut key assigning

Attached to Project: Community Packages
Opened by hrca (hrca) - Sunday, 21 February 2021, 17:02 GMT
Last edited by Evangelos Foutras (foutrelis) - Monday, 24 May 2021, 16:53 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hello, I am still confused about source of bug(package, xfce, or arch), So I am reporting as it is.
I am reporting bug in reference to one package, but I seen this weird behavior due to this bug in other packages also, but with this package it is consistent, So it will help in pinpointing cause.

System: 5.10.16-arch1-1
Desktop Environment: xfce
Package: xdotool version 3.20160805.1

I wanted to auto type youtube url using xdotool, so I assigned

xdotool type 'https://youtube.com' to Win+y

But when I press this, two things happens

1. Prints Gibberish
tt.co:M//outube.cohmt
or
comtt://outu.comt://outu.comtt://mtt:/

2. My other keyboard mappings(hotkeys) also gets executed all at once, ex. "Win+f" "firefox", "Win+l" "Lock", "Win+q" "emacs" etc.

And same happens even if I put code in script too.

Workaround:
If I create some delay before xdotool then it works fine.

sleep 0.5
xdotool type 'https://youtube.com'


PS: I also tried to report on "https://github.com/jordansissel/xdotool/issues/319". But there was no response and now I discovered that this bug is not specific to that package, So I am reporting here.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Monday, 24 May 2021, 16:53 GMT
Reason for closing:  Upstream
Additional comments about closing:  Not sure if this is solvable by upstream, but in any case it's very unlikely to be a packaging bug.
Comment by Evangelos Foutras (foutrelis) - Monday, 22 February 2021, 07:59 GMT
I'm not sure what's at fault here either, maybe xdotool is doing the typing and the keys are being interpreted together with the Super (Win) key.

As a workaround, this seems to work: "xdotool sleep .2 type --clearmodifiers https://youtube.com/"; -- You still need to wait until it's finished typing otherwise you can get into the original issue again; same as if it were you doing the typing and hitting the Super key again.
Comment by hrca (hrca) - Monday, 22 February 2021, 19:12 GMT
I tried to use Ctrl instead of Win key and used this mapping

xdotool type 'ssssssssssss''

So when I pressed hotkey combination in sublime, it executed Ctrl + s (Save command) and entered file name "ssss"

So I think you are right. It takes some time before it starts to type and before that, it uses them as key combinations with whatever key assigned to hotkey. In previous case that was Win key, and in this case it is Ctrl Key.
Comment by hrca (hrca) - Tuesday, 23 February 2021, 04:31 GMT
I think command execution is linked to Key Down event, So further keys pressed are combining with hotkey, while it still pressed.
This problem can be solved if execution will be linked with Key Up event, but that will increase delay for other commands too.

Loading...