Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69711 - [grub] Rebuild of grub since 2021-02-15 generates 100M+ images

Attached to Project: Arch Linux
Opened by Nigel Kukard (nkukard) - Saturday, 20 February 2021, 09:06 GMT
Last edited by Christian Hesse (eworm) - Monday, 22 February 2021, 06:52 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Ronald van Haren (pressh)
Christian Hesse (eworm)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Hi guys, I do regular rebuilds of grub for unit testing and since around 2021-02-15 its been generating 100M+ .img files.

There is another reference to this on linuxquestions.org from a few days ago:
https://www.linuxquestions.org/questions/slackware-14/grub-error-in-latest-slackware-current-4175690623/page2.html#post6221162


Additional info:
* package version(s)
since 2.04-9, since 2021-02-15

Steps to reproduce:
makepkg -s
install grub package

# pacman -U grub-2:2.04-9-x86_64.pkg.tar.zst
Packages (1) grub-2:2.04-9

Total Installed Size: 930.69 MiB
Net Upgrade Size: 0.00 MiB

root# ls -la /usr/lib/grub/i386-pc/*.img /usr/lib/grub/i386-efi/*.img /usr/lib/grub/x86_64-efi/*.img
-rw-r--r-- 1 root root 64836 Feb 20 08:20 /usr/lib/grub/i386-efi/kernel.img
-rw-r--r-- 1 root root 134481116 Feb 20 08:20 /usr/lib/grub/i386-pc/boot_hybrid.img
-rw-r--r-- 1 root root 134481116 Feb 20 08:20 /usr/lib/grub/i386-pc/boot.img
-rw-r--r-- 1 root root 134481116 Feb 20 08:20 /usr/lib/grub/i386-pc/cdboot.img
-rw-r--r-- 1 root root 134480092 Feb 20 08:20 /usr/lib/grub/i386-pc/diskboot.img
-rw-r--r-- 1 root root 29276 Feb 20 08:20 /usr/lib/grub/i386-pc/kernel.img
-rw-r--r-- 1 root root 134488284 Feb 20 08:20 /usr/lib/grub/i386-pc/lnxboot.img
-rw-r--r-- 1 root root 134479612 Feb 20 08:20 /usr/lib/grub/i386-pc/lzma_decompress.img
-rw-r--r-- 1 root root 134481116 Feb 20 08:20 /usr/lib/grub/i386-pc/pxeboot.img
-rw-r--r-- 1 root root 101920 Feb 20 08:20 /usr/lib/grub/x86_64-efi/kernel.img


This causes installations to fail... here is an easy reproducer...
root# /usr/bin/grub-mkimage --prefix /boot/grub --format i386-pc-eltorito --output /tmp/eltorito.img biosdisk iso9660
/usr/bin/grub-mkimage: error: Decompressor is too big.

This task depends upon

Closed by  Christian Hesse (eworm)
Monday, 22 February 2021, 06:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  grub 2:2.04-10
Comment by Colin Watson (cjwatson) - Sunday, 21 February 2021, 11:29 GMT
This looks like the bug fixed upstream by https://git.savannah.gnu.org/cgit/grub.git/commit/?id=6643507ce30f775008e093580f0c9499dfb2c485, so I'd suggest cherry-picking that.
Comment by Nigel Kukard (nkukard) - Sunday, 21 February 2021, 12:43 GMT
Added patch and everything works 100%

Loading...