Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69710 - [nextcloud]: Upgrade on first point release

Attached to Project: Community Packages
Opened by Tormod Volden (tormod) - Saturday, 20 February 2021, 08:39 GMT
Last edited by David Runge (dvzrv) - Saturday, 20 February 2021, 23:26 GMT
Task Type General Gripe
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

Thanks for keeping this package so up to date, but it is sometimes too fast :)

Upstream doesn't recommend upgrading to new major .0 releases, but awaiting the first .1 point release for upgrades[1]. The .0 releases are fine for new installations. Would it be possible to follow this recommendation by default, without users manually having to manually block and consider every package upgrade?

Also, e.g. 21.0.0-1 is offered for upgrade before upstream has made an official release (and posted release notes). Releasing is often more than just making a git tag.

[1] https://nextcloud.com/release-channels/
"new release is typically only available in the stable channel after the first minor release."
"Users can always upgrade sooner by choosing the beta channel,"
I interpret this as .0 should be considered a beta version.

Steps to reproduce:
1. Have nextcloud 20.0.7-1 installed
2. See nextcloud 21.0.0-1 being offered
3. Look up https://nextcloud.com/changelog/ and see nothing about a 21 version
4. Read https://nextcloud.com/release-channels/ and conclude I should really wait for 21.0.1 before upgrading
This task depends upon

Closed by  David Runge (dvzrv)
Saturday, 20 February 2021, 23:26 GMT
Reason for closing:  Fixed
Additional comments about closing:  A note is added to the PKGBUILD to prevent early updates on first point release.
Comment by Sergej Pupykin (sergej) - Saturday, 20 February 2021, 09:34 GMT
Probably it was too fast but nextcloud is downloaded from https://download.nextcloud.com/server/releases/nextcloud-${pkgver}.tar.bz2 not from git tag.
Comment by David Runge (dvzrv) - Saturday, 20 February 2021, 10:42 GMT
@tormod: It is certainly something that can be considered for the next major upgrade of nextcloud!

@sergej: That's one of the reasons why I wanted to wait and have it in [community-testing] first (as mentioned in my mail).
Some of the apps also take some time to catch up with major releases and it's definitely nicer to have them working, when upgrading.
Comment by Gunnar Bretthauer (Taijian) - Saturday, 20 February 2021, 15:24 GMT
Yeah, I'd like to second the OP's request.

I applaud your enthusiasm for providing the 'latest and greatest' version of this package at all times, but please understand that this is something that people actually use on servers that serve very important functions for them. And the roll-out for this particular upgrade has been anything but smooth or user-friendly, so far (just consider the fact that you are already on release -4...).

Especially when introducing breaking changes in a PKGBUILD (and let's be real, 21.0.0-4 still BREAKS every single existing setup out there), please take more time to actually consider the changes, make sure they are ironed out in every single line and file in the build package, and - and I cannot stress this enough - make sure beforehand, that you either provide concise and thourough instructions for people upgrading your package to unfuck their systems afterwards. Or, you know, not fuck them up in the first place...
Comment by kpcyrd (kpcyrd) - Saturday, 20 February 2021, 16:40 GMT
@Taijian regardless of the issue at hand, please keep in mind that Arch Linux is maintained by unpaid volunteers.
Comment by Gunnar Bretthauer (Taijian) - Saturday, 20 February 2021, 17:43 GMT
@kpcyrd: I do, trust me, I do. I understand that mistakes happen and I am utterly convinced that Sergej and David really are good people and want to do good by us by sacrificing their time and energy in maintaining this package.

Nevertheless, I am currently angry at how botched the roll-out of this update has been and how much breakage it has introduced into a great many people's lives, when all of that could have been avoided by going about this in less of a YOLO manner. This could have been a simple upgrade. Now I (and anyone fortunate enough to have become aware of the issues here before breaking their installs) have to set a day aside at some point in the future to completely reconfigure our servers. Others will spend lots of time just trying to recover from this. That is a lot of personhours wasted and a lot of people's lives negatively affected. And it could have been avoided by using community-testing, soliciting input from users, or making an announcement about breaking changes before install (via NEWS).

A simple apology can go a long way when you notice that you fucked up, even if you are just a volunteer (as opposed to an employee).

I hope this serves as a learning experience for everyone involved.
Comment by Sergej Pupykin (sergej) - Saturday, 20 February 2021, 19:14 GMT
I generally agree but in this case 2nd pkgrel was already working and came immediately after 1st one. I tested it with
nextcloud-app-bookmarks 1:4.0.8-1
nextcloud-app-calendar 1:2.1.3-1
nextcloud-app-contacts 3.4.3-1
nextcloud-app-deck 1:1.2.4-1
nextcloud-app-gpxpod 4.2.6-1
nextcloud-app-mail 1.8.0-1
nextcloud-app-maps 0.1.8-1
nextcloud-app-notes 4.0.2-1
nextcloud-app-phonetrack 0.6.7-1
nextcloud-app-social 0.4.2-1
nextcloud-app-spreed 1:10.1.1-1
nextcloud-app-tasks 0.13.6-1
apps.

But maybe it has some bugs I did not found.
Comment by Sergej Pupykin (sergej) - Saturday, 20 February 2021, 19:29 GMT
I added

[[ "$pkgver" == *.0 ]] && { echo "wait for .1 version" ; exit 1; }

to pkgbuild so .0 version will not be built if I forget next time.
Comment by Tormod Volden (tormod) - Saturday, 20 February 2021, 22:02 GMT
I see there is already a nextcloud-testing package, so +1 on using that for staging and being more conservative in main nextcloud package.

Thanks a lot for already masking the .0 releases!

I hope the 21.0.1-x package will get into shape and be well documented before I need to upgrade from my 20.0.7 installation.
Comment by David Runge (dvzrv) - Saturday, 20 February 2021, 23:13 GMT
@sergej: I had to replace that addition to the PKGBUILD with a note (it made running updpkgsums on the PKGBUILD impossible).

Loading...