Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69707 - [linux-lts/linux] 5.10.17-1 NVME drive is not detected

Attached to Project: Arch Linux
Opened by Alex (alex_bgoode) - Saturday, 20 February 2021, 00:02 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 28 February 2021, 15:36 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Andreas Radke (AndyRTR)
Jan Alexander Steffens (heftig)
Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

During boot the drive is not detected resulting in me being dropped into an emergency shell.
Everything is working fine the previous kernel 5.498-1-lts.
I also tried 5.11 from testing which results in the same error.

ERROR: resume: hibernation device '/dev/mapper/arch-swap' not found
ERROR: device '/dev/mapper/arch-root' not found. Skipping fsck.
You are now being dropped into an emergency shell.
sh: can't access tty; job control turned off
[rootfs ]# _


Additional info:
* package version(s)
* config and/or log files etc.

lsblk -o "NAME,MAJ:MIN,RM,SIZE,RO,FSTYPE,MOUNTPOINT" ~

NAME MAJ:MIN RM SIZE RO FSTYPE MOUNTPOINT
nvme0n1 259:0 0 476.9G 0
├─nvme0n1p1 259:1 0 100M 0 vfat /boot/efi
├─nvme0n1p2 259:2 0 250M 0 ext2 /boot
└─nvme0n1p3 259:3 0 476.6G 0 crypto_LUKS
└─arch-encrypted 254:0 0 476.6G 0 LVM2_member
├─arch-swap 254:1 0 16G 0 swap [SWAP]
└─arch-root 254:2 0 460.6G 0 ext4 /


Hardware:
Model Number: WDC PC SN720 SDAQNTW-512G-1001

* link to upstream bug report, if any

Steps to reproduce:
1) Install kernel version 5.10
2) Reboot

This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 28 February 2021, 15:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  Solved by firmware update. Problem for the device is already documented in the Arch wiki
Comment by Alex (alex_bgoode) - Sunday, 28 February 2021, 15:05 GMT
The bug was fixed by a firmware update of the nvme device (https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_X1_Carbon_(Gen_6)#nvme_issues)

Loading...