Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69706 - [xorg-xwayland] latest update breaks scrolling on chromium and crhomium based applications

Attached to Project: Arch Linux
Opened by 0xD6 (acidpointer) - Friday, 19 February 2021, 13:44 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 01 September 2021, 07:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I've installed latest update of xorg-xwayland.
After reboot, chromium and code(vscode) became unusable.
Scrolling has become unpredictable. When trying to scroll through the document, scrolling could stop working at any time, its speed could decrease. In theory, only GTK applications are problematic(telegram-desktop worked fine).

Downgrading to version 1.20.0.r844.g1e72c3ce8-1 solved the problem.

Additional info:
* package version(s)
xorg-xwayland 1.20.0.r853.gfdc61c5a3-1
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
1. Install xorg-xwayland 1.20.0.r853.gfdc61c5a3-1
2. Reboot the system, or login/logout
3. Launch chromium or code(vscode)
4. Try to scroll large document or page
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 01 September 2021, 07:40 GMT
Reason for closing:  No response
Comment by Andreas Radke (AndyRTR) - Saturday, 20 February 2021, 10:21 GMT
Please report this upstream and probably also bisect to find the commit causing this one.

Loading...