Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#69684 - [glibc] new --enable-kernel broke systems using older kernels

Attached to Project: Arch Linux
Opened by Makoto Mizukami (makotom) - Thursday, 18 February 2021, 02:59 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 18 February 2021, 03:13 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No



As of glibc 2.33-4, `--enable-kernel` is set for compiler options.
This breaks several systems using older Linux kernel, notably WSL.

The commit message for 2.33-4 reads "enab(l)e compatibility with older (4.4+) kernels", but in fact this purged those systems.

From -

> ‘--enable-kernel=version’
> This option is currently only useful on GNU/Linux systems. The version parameter should have the form X.Y.Z and describes the smallest version of the Linux kernel the generated library is expected to support. The higher the version number is, the less compatibility code is added, and the faster the code gets.

Additional info:
* package version(s): glibc 2.33-4

Steps to reproduce:

This is how I confirmed the issue. You should be able to reproduce this issue on any environment using kernel 4.4.0 with any user-space executables dynamically linked to glibc.

1. Install Arch Linux on WSL1
2. pacman -Syu
3. w

Expected behaviour:
w should work normally.

Actual behaviour:
It shows `Fatal: kernel too old` error message.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 18 February 2021, 03:13 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#69663