Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69664 - [linux] AMD Ryzen 4500U laptopfails to shutdown correctly with immediate reboot with 5.11

Attached to Project: Arch Linux
Opened by Mike Cloaked (mcloaked) - Tuesday, 16 February 2021, 17:28 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 05 March 2021, 13:29 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

HP Envy X360 15-en0000na laptop runs kernel 5.11 without problems until the machine is shut down. This seems only to occur on machines with AMD Ryzen CPU. My Intel machines do not have this issue with kernel 5.11. If shutdown is requested from within the plasma desktop, or if only using a VT console and the command "systemctl poweroff" or "systemctl halt" are issued, then the system shuts down but immediately reboots again, and will not remain powered off or halted. This is a high severity regression, since all kernels 5.10.x do not have this issue.

Additional info:
* package version(s) Kernel 5.11 currently in testing

* config and/or log files etc.
* link to upstream bug report, if any

https://bugzilla.kernel.org/show_bug.cgi?id=211799

Steps to reproduce:

Update kernel to 5.11, and boot. Then try to shutdown or poweroff - the system will shut down, but immediately reboot - so the only way to power off is to press and hold the power button for an unclean power off which is highly unsatisfactory. Perhaps 5.11 will not be pushed to the repos until the upstream bug is fixed?
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 05 March 2021, 13:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 5.11.arch2-1 and later
Comment by Mike Cloaked (mcloaked) - Thursday, 18 February 2021, 23:17 GMT
With a lot of help with building bisect kernels from loqs a kernel bisection has been completed identifying the first bad commit, and this is reported on the upstream bug at:
https://bugzilla.kernel.org/show_bug.cgi?id=211799#c19

Hopefully a solution will be found as a fix for the bad commit.
Comment by Mike Cloaked (mcloaked) - Friday, 19 February 2021, 11:47 GMT
linux-5.11-arch2-1 has the fix from https://gitlab.freedesktop.org/drm/amd/-/issues/1499 and another fix from https://gitlab.freedesktop.org/drm/amd/-/issues/1487 and is currently in the [testing] repo. I have installed and tested this kernel and it fixes the shutdown going to reboot instead of poweroff, for me. So with these new patches the issue is fixed for me.
Comment by Mike Cloaked (mcloaked) - Friday, 05 March 2021, 12:39 GMT
This is resolved in kernel 5.11.3 for me.

Loading...