Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69656 - [gimp] MimeType overkill

Attached to Project: Arch Linux
Opened by Hauke (otterwise) - Tuesday, 16 February 2021, 10:21 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 16 February 2021, 11:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

### Environment/Versions

- GIMP version: 2.10.22
- Package: https://archlinux.org/packages/extra/x86_64/gimp/
- Operating System: EndeavourOS Arch Linux with KDE Plasma Desktop

### Description of the bug

Every time I upgrade GIMP with pacman, it is set as default for a wide range of MimeTypes - mostly image files but also a bunch of other stuff.

I've had this problem for years and over several Linux OS installs. This behavior is absolutely nonsensical. The default file association for normal image files should be viewers, not editors. It's very inconvenient to have to manually fix file associations for so many filetypes after every upgrade.

Apparently this has been a problem since 2010: https://forums.fedoraforum.org/showthread.php?309037-GIMP-dumping-on-mimetypes

I filed a bug report at Gnome but they said the problem must be downstream: https://gitlab.gnome.org/GNOME/gimp/-/issues/6449#note_1037466

### Reproduction

Always. Every damn time there's a new GIMP version.

Reproduction steps:

1: Install GIMP on Linux (e.g. $ pacman -S gimp).

2: Open jpg, bmp, etc. with default app.

Expected result:

The file is opened with Gwenview, the KDE default image viewer.

Actual result:

The file is opened with GIMP, which takes too long to load and isn't designed for viewing.
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 16 February 2021, 11:57 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Please report this to your distribution
Comment by Hauke (otterwise) - Tuesday, 16 February 2021, 10:23 GMT
PS: Yes I'm using the official Arch repos.

And sure, this happens across distros, but if the blame doesn't lie with GIMP, where else could it lie other than with the distros' install scripts? Sorry if I'm missing something obvious.

In Windows it's standard to ask the user which file associations should be registered during install. Shouldn't something like this be possible with pacman, at least via some command line option or config file?

Loading...