Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69635 - [audacious] add gtk3 support

Attached to Project: Arch Linux
Opened by Andrey (Gendalf) - Sunday, 14 February 2021, 01:10 GMT
Last edited by Evangelos Foutras (foutrelis) - Sunday, 14 February 2021, 13:42 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Hello. Audacious 4.1 can use both Qt+GTK interface. Switching between Qt and GTK modes can now be done right from the Settings window.

Please add GTK support.

https://audacious-media-player.org/news/51-audacious-4-1-released


Steps to reproduce:

Please add gtk3 dependency and remove --disable-gtk from PKGBUILD
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Sunday, 14 February 2021, 13:42 GMT
Reason for closing:  Deferred
Additional comments about closing:  Will revisit this once GTK 3 support is merged into upstream's master branch and officially released.
Comment by Evangelos Foutras (foutrelis) - Sunday, 14 February 2021, 08:29 GMT
It requires GTK 2 which has reached its end of life. Maybe once it supports GTK 3 it'll be a more attractive option, even though it'd probably still hard-depend on both toolkits which isn't very nice.
Comment by Andrey (Gendalf) - Sunday, 14 February 2021, 12:55 GMT
GTk3 support too. By default gtk enabled in configure script now in version 4.1. Please add gtk3 dependency and remove --disable-gtk.
Comment by Evangelos Foutras (foutrelis) - Sunday, 14 February 2021, 13:05 GMT
It specifically wants GTK 2. It works for you because you have gtk2 installed, but in a chroot you'll see:

> checking for GTK... no
> configure: error: Package requirements (gtk+-2.0 >= 2.24) were not met:
>
> Package 'gtk+-2.0', required by 'virtual:world', not found

[1] https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_clean_chroot
Comment by Eli Schwartz (eschwartz) - Sunday, 14 February 2021, 13:31 GMT
I don't see anywhere in that news link stating that they've updated their gtk support to 3.x

Loading...