Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69634 - [signal-desktop] Missing dependency gtk3

Attached to Project: Community Packages
Opened by Arne Beer (Nukesor) - Saturday, 13 February 2021, 14:59 GMT
Last edited by kpcyrd (kpcyrd) - Sunday, 14 February 2021, 12:50 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Levente Polyak (anthraxx)
kpcyrd (kpcyrd)
Santiago Torres (sangy)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Missing dependency gtk3 on signal-desktop package.

Additional info:

Version: 1.39.6-1
No configuration files, clean install.

Error:

signal-desktop: error while loading shared libraries: libXcomposite.so.1: cannot open shared object file: No such file or directory

Missing libraries/packages are: gtk3, libxcomposite, libxtst
However the other two are direct dependencies of gtk3, so adding this one does the job.


Steps to reproduce:

- Run headless machine
- Install signal-desktop
- Run signal-desktop
This task depends upon

Closed by  kpcyrd (kpcyrd)
Sunday, 14 February 2021, 12:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.39.6-2
Comment by Doug Newgard (Scimmia) - Saturday, 13 February 2021, 15:17 GMT
Looks like gtk3 and nss are the absolute minimum that need to be added.

Edit, nevermind, nss is in the libvips tree.

Loading...