Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69627 - AF_NETLINK option for RestrictAddressFamilies in mailman3's unit file prevents it from starting

Attached to Project: Community Packages
Opened by Patrick Ben Koetter (Patrick) - Friday, 12 February 2021, 19:23 GMT
Last edited by David Runge (dvzrv) - Tuesday, 18 May 2021, 08:16 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Starting a vanilla mailman3 installation on a vanilla ARCH install (with IPv4 and IPv6) fails, because the postmap command is not allowed to open sockets/the type of sockets it needs. The postmap command will fail issuing "Address family not supported by protocol" as error. Lessening the RestrictAddressFamilies limits in mailman's unit file will let it start.


Additional info:
* community/mailman3 3.3.2-3
* log attached

Steps to reproduce:
1. Install mailman3 via pacman
2. Run 'systemctl start mailman3.service'
3. Copy /usr/lib/systemd/system/mailman3.service to /etc/systemd/system/mailman3.service
4. Remove option AF_NETLINK from RestrictAddressFamilies parameter *or* exchange it forAF_UNIX AF_INET AF_INET6 in /etc/systemd/system/mailman3.service
5. systemctl daemon-reload
6. systemctl start mailman3.service

I'm not sure if my proposed solution is the way to go, but removing AF_NETLINK did it for me.
This task depends upon

Closed by  David Runge (dvzrv)
Tuesday, 18 May 2021, 08:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with mailman3 3.3.4-2 (in community-staging)
Comment by David Runge (dvzrv) - Tuesday, 18 May 2021, 08:14 GMT
@Patrick: Thanks for the report.

I am running mailman3.service with AF_NETLINK ignored (in conjunction with postfix). It seems it really depends on the setup.

However, I will remove the setting in an upcoming pkgrel bump of the package.

Loading...