Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69611 - [lvm2] Some LVs are not detected since last update

Attached to Project: Arch Linux
Opened by Oleksandr Natalenko (post-factum) - Wednesday, 10 February 2021, 16:37 GMT
Last edited by Christian Hesse (eworm) - Friday, 12 February 2021, 08:09 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Once lvm2 got updated to 2.03.11-3, I cannot boot properly any more:

```
[~]> sctl --failed
UNIT LOAD ACTIVE SUB DESCRIPTION
● lvm2-pvscan@253:2.service loaded failed failed LVM event activation on device 253:2
● lvm2-pvscan@9:0.service loaded failed failed LVM event activation on device 9:0

Feb 10 17:24:56 spock systemd[1]: lvm2-pvscan@253:2.service: State 'stop-sigterm' timed out. Killing.
Feb 10 17:24:56 spock systemd[1]: lvm2-pvscan@253:2.service: Killing process 643 (lvm) with signal SIGKILL.
Feb 10 17:24:56 spock systemd[1]: lvm2-pvscan@253:2.service: Main process exited, code=killed, status=9/KILL
Feb 10 17:24:56 spock systemd[1]: lvm2-pvscan@253:2.service: Failed with result 'timeout'.
Feb 10 17:24:56 spock systemd[1]: Stopped LVM event activation on device 253:2.
Feb 10 17:24:56 spock audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=lvm2-pvscan@253:2 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Feb 10 17:24:56 spock kernel: audit: type=1130 audit(1612974296.950:93): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=lvm2-pvscan@253:2 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Feb 10 17:24:57 spock systemd[1]: dev-disk-by\x2duuid-00f64344\x2d2a08\x2d47c7\x2d9a20\x2d6cbfd4a5bc96.device: Job dev-disk-by\x2duuid-00f64344\x2d2a08\x2d47c7\x2d9a20\x2d6cbfd4a5bc96.device/start timed out.
Feb 10 17:24:57 spock systemd[1]: Timed out waiting for device /dev/disk/by-uuid/00f64344-2a08-47c7-9a20-6cbfd4a5bc96.
Feb 10 17:24:57 spock systemd[1]: Dependency failed for /mnt/mail.
Feb 10 17:24:57 spock systemd[1]: Dependency failed for Local File Systems.
Feb 10 17:24:57 spock systemd[1]: local-fs.target: Job local-fs.target/start failed with result 'dependency'.
Feb 10 17:24:57 spock systemd[1]: local-fs.target: Triggering OnFailure= dependencies.
Feb 10 17:24:57 spock systemd[1]: mnt-mail.mount: Job mnt-mail.mount/start failed with result 'dependency'.
Feb 10 17:24:57 spock systemd[1]: Dependency failed for File System Check on /dev/disk/by-uuid/00f64344-2a08-47c7-9a20-6cbfd4a5bc96.
Feb 10 17:24:57 spock systemd[1]: systemd-fsck@dev-disk-by\x2duuid-00f64344\x2d2a08\x2d47c7\x2d9a20\x2d6cbfd4a5bc96.service: Job systemd-fsck@dev-disk-by\x2duuid-00f64344\x2d2a08\x2d47c7\x2d9a20\x2d6cbfd4a5bc96.service/start failed with result 'dependency'.
Feb 10 17:24:57 spock systemd[1]: dev-disk-by\x2duuid-00f64344\x2d2a08\x2d47c7\x2d9a20\x2d6cbfd4a5bc96.device: Job dev-disk-by\x2duuid-00f64344\x2d2a08\x2d47c7\x2d9a20\x2d6cbfd4a5bc96.device/start failed with result 'timeout'.
```

Although the LV is present:

```
LV VG Attr LSize Pool Origin Data% Meta% Move Log Cpy%Sync Convert
boot base -wi-ao---- 384,00m
sys base -wi-ao---- <464,50g
home sys Vwi-aotz-- 462,00g pool 17,18
mail sys Vwi-a-tz-- 462,00g pool 0,30
pool sys twi-aotz-- 462,25g 30,93 17,44
root sys Vwi-aotz-- 462,00g pool 4,71
swap sys -wi-ao---- 2,00g
vm-01-archlinux-sda sys Vwi-a-tz-- 8,00g pool 41,21
vm-02-windows-sda sys Vwi-a-tz-- 50,00g pool 62,34
vms sys Vwi-aotz-- 462,00g pool 1,29
```

it doesn't seem to be picked up to appear here:

```
$ ls /dev/sys
home root swap vm-01-archlinux-sda vm-02-windows-sda vms

$ ls /dev/mapper
base-boot control sys-home sys-pool-tpool sys-pool_tmeta sys-swap sys-vm--02--windows--sda
base-sys sys sys-pool sys-pool_tdata sys-root sys-vm--01--archlinux--sda sys-vms
```

The last time I experienced this it was fixed here: https://github.com/archlinux/svntogit-packages/commit/177624fb6c30271e04104df40e1e772f61fca3e0#diff-3e341d2d9c67be01819b25b25d5e53ea3cdf3a38d28846cda85a195eb9b7203a

But since lvmetad is now gone, probably, systemd-udevd.service should be put in After= of another unit?
This task depends upon

Closed by  Christian Hesse (eworm)
Friday, 12 February 2021, 08:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  lvm2 2.03.11-4
Comment by Oleksandr Natalenko (post-factum) - Wednesday, 10 February 2021, 16:48 GMT
Adding this:

```
After=systemd-udevd.service
```

to /usr/lib/systemd/system/lvm2-pvscan@.service seems to fix the issue. Will observe for a longer time.
Comment by Christian Hesse (eworm) - Thursday, 11 February 2021, 11:25 GMT
So lvm2 2.03.11-4 in [testing] fixes this for you?
Comment by Oleksandr Natalenko (post-factum) - Thursday, 11 February 2021, 13:18 GMT
So far, yes, I've deployed this on several machines, and all of those reboot fine. You may want to give me a couple of days more so that I reboot them several times again just to be sure.
Comment by Christian Hesse (eworm) - Thursday, 11 February 2021, 13:26 GMT
Sure. Well, most important is that nobody steps up with new regressions.
Comment by Christian Hesse (eworm) - Friday, 12 February 2021, 08:08 GMT
The package received its signoffs, so looks good.

Loading...