Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69600 - [util-linux] fstrim doesn't work on NTFS partitions

Attached to Project: Arch Linux
Opened by frederick_metzengerstein (metzengerstein) - Tuesday, 09 February 2021, 18:24 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 30 March 2021, 11:50 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Running fstrim on a NTFS partition (mounted via ntfs-3g) results in the error:
"fstrim: /media/windows: FITRIM ioctl failed: Device or resource busy"

The error appears since upgrading from kernel "5.9.14.arch1-1" to "5.10.3.arch1-1".

Package version: util-linux 2.36.1-4
Kernel version: 5.10.3.arch1-1

Related forum thread: https://bbs.archlinux.org/viewtopic.php?id=262243
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 30 March 2021, 11:50 GMT
Reason for closing:  Upstream
Additional comments about closing:  Fixed in linux-5.11.7.arch1.
Comment by loqs (loqs) - Wednesday, 10 February 2021, 02:39 GMT
Please check 5.10.1.arch1-1 to see if the issue is triggered by the update to 5.10 rather than the disabling of the in kernel NTFS support in 5.10.3.arch1-1.
You can obtain the kernel from [1] is you do not have it in the system's package cache.

[1] https://archive.archlinux.org/packages/l/linux/
Comment by frederick_metzengerstein (metzengerstein) - Wednesday, 10 February 2021, 18:33 GMT
I get the same error with 5.10.1.arch1-1.
Comment by loqs (loqs) - Wednesday, 10 February 2021, 20:18 GMT
Is the issue still present using linux 5.11-rc7 available from [1]?

[1] https://wiki.archlinux.org/index.php/Unofficial_user_repositories#miffe
Comment by Lester B (lestb2) - Friday, 12 February 2021, 03:22 GMT Comment by loqs (loqs) - Saturday, 13 February 2021, 00:09 GMT
So the change is intended and hence not a bug?
Comment by Richard Jones (rwmjones) - Sunday, 14 February 2021, 15:35 GMT
It's a kernel bug, see https://bugzilla.kernel.org/show_bug.cgi?id=211167
(Edit: oops I see you've already linked to that)
Comment by Lester B (lestb2) - Saturday, 20 March 2021, 00:17 GMT
I didn't encounter the issue anymore with linux-5.11.7.arch1.

Loading...