Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69569 - [glib2] geeqie hangs on launch when launched via desktop entry (i.e. -r %F)

Attached to Project: Arch Linux
Opened by Peter Weber (hoschi) - Saturday, 06 February 2021, 19:12 GMT
Last edited by Jan Alexander Steffens (heftig) - Sunday, 07 February 2021, 23:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Hello!
Description:

I've update my system today (last update was 28-01-2021) and now I cannot launch Geeqie through GNOME-Shell or Nautilus. It seem to be related to the remote option "-r, --remote" because launches from the terminal work. The "-r" option is used by the desktop entry file "/usr/share/applications/geeqie.desktop".

Another suspect are the changes to poppler, imagemagick and graphicsmagick. I've also removed libmagick6 as "pacman -Qdt" told me. I didn't followed that path further, because the "-r" option seem to be a trigger.

Additional info:
* package version(s): geeqie 1.6-4
* config and/or log files etc.:
part of pacman.log from 2021
output of $ geeqie --debug -r


Steps to reproduce:
GNOME
1.) Alt+F1
2.) Enter "geeqie"
3.) Hit "Enter" -> Geeqie hangs
Nautilus
1.) Double click on a PNG, JPEG... -> Geeqie hangs
Terminal:
1.) $ geeqie -r or $ geeqie --debug -r -> Geeqie hangs


Thank you
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Sunday, 07 February 2021, 23:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  glib2 2.66.6-2
Comment by Andreas Radke (AndyRTR) - Saturday, 06 February 2021, 19:48 GMT
No problem here using i3-wm from command line or Rofi menu. No Gnome here. So I can't confirm.

Maybe try to get help at our IRC channels or the forum or even ask upstream.
Comment by Peter Weber (hoschi) - Saturday, 06 February 2021, 20:18 GMT
Thanks for the quick response. Hm. At least the „-r“ option should have triggered it. Do you use hardware acceleration (Preferences->Image)?
Comment by Peter Weber (hoschi) - Saturday, 06 February 2021, 21:49 GMT
Forget that! I doesn't matter whether you're using hardware acceleration or not. Also X11 or Wayland doesn't matter. And libmagick6 also doesn't matter.
It is caused by some change applied through Archlinux between 03-02-2021 and today. Which doesn't mean upstream Geeqie doesn't need take care of it.

// edit
Also not poppler and poppler-glib. Come out bug...I know you are there :)
Comment by Peter Weber (hoschi) - Saturday, 06 February 2021, 22:15 GMT
I've have it. It is caused by the upgrade from glib2 "2.66.4-2" to glib2 "2.66.6-1"
Comment by Peter Weber (hoschi) - Saturday, 06 February 2021, 22:43 GMT
It is not caused by glib "2.66.5" which I've compiled myself on my machine.
https://gitlab.gnome.org/GNOME/glib/-/commits/glib-2-66/

// edit
The g_memdup2() looks suspicious to me but that is a guess and nothing more. I reported this now to Geeqie and maybe they can give us or GLIB2 a hint :)
https://github.com/BestImageViewer/geeqie/issues/865

Comment by Andreas Radke (AndyRTR) - Sunday, 07 February 2021, 20:37 GMT
Turns out o be glib2 bug it seems: https://gitlab.gnome.org/GNOME/glib/-/issues/2323

Jan, please also follow this one.

Loading...