Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69550 - [linux-lts-headers] 5.4.95-1 dkms script "fixdep" links to unavailable glibc version

Attached to Project: Arch Linux
Opened by Magnus GroƟ (Magnus21) - Friday, 05 February 2021, 21:33 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 05 February 2021, 23:29 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: The fixdep script seems to be linked to the wrong glibc version:

ldd /usr/lib/modules/5.4.95-1-lts/build/scripts/basic/fixdep
/usr/lib/modules/5.4.95-1-lts/build/scripts/basic/fixdep: /usr/lib/libc.so.6: version `GLIBC_2.33' not found (required by /usr/lib/modules/5.4.95-1-lts/build/scripts/basic/fixdep)

At the point of writing, glibc is at version 2.32. glibc 2.33 is only available in the testing repo.
So the fix would be one of the following:
- Rebuild linux-lts-headers to link against glibc 2.32
- Release glibc 2.33 to the general public by moving it out of testing


Right now all dkms hooks fail to build, because the fixdep script cannot start. Attached is one such failed dkms build.
   make.log (0.9 KiB)
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 05 February 2021, 23:29 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#69549 
Don't make duplicates for any reason
Comment by Jon (Doogie544) - Friday, 05 February 2021, 22:11 GMT
I can confirm this as well. I have the same error for the same module.

HOWEVER, the severity of this bug needs to be moved to HIGH or CRITICAL. It must affect any dkms install on this kernel, Nvidia-dkms will fail as well with the identical error.

It is specific to this kernel, to test this I installed `linux-zen` as well as it's headers and both my nvidia as well as the loopback module installed successfully with no errors.

Obviously if the nvidia-dkms drivers fail to install the bug is much more important than just a "Low" priority.

I do see that glibc 2.33-2 is in testing but it is not in the standard repos yet.


nvidia/460.39/build/nvidia/nv-dma.o] Error 1
make[2]: *** Deleting file '/var/lib/dkms/nvidia/460.39/build/nvidia/nv-dma.o'
scripts/basic/fixdep: /usr/lib/libc.so.6: version `GLIBC_2.33' not found (required by scripts/basic/fixdep)

Loading...