Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69539 - [sagemath] lrcalc and lrcalc1 are in conflict

Attached to Project: Community Packages
Opened by Philippe Léveillé (phleva) - Friday, 05 February 2021, 04:31 GMT
Last edited by Antonio Rojas (arojas) - Friday, 05 February 2021, 07:00 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: dependency issues with lrcalc and lrcalc1 caused by sagemath

Additional info:
version 9.2-9 depended on lrcalc. This has been replaced by lrcalc1 in version 9.2-10. I am no expert but would there be a way to limit the acceptable version of lrcalc=1.2-4 for sagemath instead of creating a "new" legacy package.

Steps to reproduce:
currently installed on the system: sagemath 9.2-9, lrcalc 1.2-4
pacman -Syu tries to install sagemath 9.2-10, lrcalc1 1.3-1
result: lrcalc1 and lrcalc are in conflict

see this forum entry for context:
https://bbs.archlinux.org/viewtopic.php?id=263214

This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 05 February 2021, 07:00 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#64785
Comment by Antonio Rojas (arojas) - Friday, 05 February 2021, 07:00 GMT
This is a bug in pacman. To workaround, use 'pacman -Suy --ignore lrcalc'

Loading...