Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69529 - Cannot use ld - libctf.so.0 missing symbol

Attached to Project: Arch Linux
Opened by Christopher Snowhill (kode54) - Thursday, 04 February 2021, 08:26 GMT
Last edited by Allan McRae (Allan) - Thursday, 04 February 2021, 11:15 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
Installing the following from testing, gcc, gcc-libs, and binutils.

Results in an ld utility that does not work, because it cannot import a symbol for libctf.so.0:

ld: symbol lookup error: /usr/lib/libctf.so.0: undefined symbol: bsearch_r

Additional info:
gcc 10.2.0-5
gcc-libs 10.2.0-5
binutils 2.36-1

Steps to reproduce:
1. Install the above packages
2. Run the `ld` command
This task depends upon

Closed by  Allan McRae (Allan)
Thursday, 04 February 2021, 11:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  binutils-2.36-2
Comment by Christopher Snowhill (kode54) - Thursday, 04 February 2021, 08:41 GMT
Amending to note that yes, I did install glibc 2.33-1 from testing as well.
Comment by Gabor Hauzer (cysp74) - Thursday, 04 February 2021, 10:27 GMT
binutils-2.36-1 affected, builds work flawlessly with binutils-2.35.1-1 as /usr/lib/libctf.so is part of binutils package.
Comment by Josip Ponjavic (metak) - Thursday, 04 February 2021, 11:06 GMT
The toolchain build order is: linux-api-headers->glibc->binutils->gcc->binutils->glibc
but the built packages show that they weren't rebuilt properly again?

Edit: The gcc-10.2.0-5 is built against the old glibc,binutils
Comment by Allan McRae (Allan) - Thursday, 04 February 2021, 11:15 GMT
The build order was followed - I have no idea how glibc and valgrind afterwards managed to build... (I have suspicions but need to investigate).

The issue is fixed in binutils-2.36-2.

Loading...