Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69502 - [chromium] getUserMedia keeps throwing with a NotReadableError.

Attached to Project: Arch Linux
Opened by CIpher (cipherallies) - Tuesday, 02 February 2021, 02:09 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 21 April 2021, 12:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Felix Yan (felixonmars)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: It is not possible to use the microphone in Chromium.

Any attempt to use the microphone results in a `Error with getUserMedia: Could not start audio source'.

Additional info:
* chrome://version output is attached.
* Firefox (tested with 85.0-1) is unaffected.

Steps to reproduce:
* Go to https://kaliatech.github.io/web-audio-recording-tests/dist/#/test1 and starts recording.
* An alert should pop up with the error.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 21 April 2021, 12:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  Assuming fixed, please reopen if there's packaging changes to be made or to backport upstream fixes.
Comment by simonzack (simonzack) - Saturday, 06 February 2021, 05:15 GMT
This also affects Vivaldi, which I suppose makes sense as it uses Chromium.

I'm using PipeWire.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 21 April 2021, 10:36 GMT
Works for me but I'm not using PipeWire. Is this still any issue for you?
Comment by simonzack (simonzack) - Wednesday, 21 April 2021, 12:04 GMT
Not anymore. I'm not sure what fixed it, but got a new Bluetooth USB adapter, and updated some of my PipeWire scripts.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 21 April 2021, 12:16 GMT
Thanks for the info. I'm guessing it could also be that Chromium 89 switched to PipeWire 0.3 (it was using libpipewire02 before that).

Loading...