Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69437 - [pulseeffects] crash due to missing dependencies in 5.0.0-1

Attached to Project: Community Packages
Opened by A. Bosch (progandy) - Monday, 25 January 2021, 13:38 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Saturday, 27 February 2021, 18:35 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Filipe Laíns (FFY00)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 6
Private No

Details

Description:

pulseeffects 5.0.0 is incompatible with pulseaudio, and should have a dependency on pipewire-pulse.
It also crashes when gst-plugin-pipewire is not installed.

$ pulseeffects

** (pulseeffects:421680): ERROR **: 14:09:08.014:
unhandled exception (type std::exception) in signal handler:
what: soe: Failed to get required plugin: pipewiresrc

[1] 421680 trace trap (core dumped) pulseeffects

The libpulse dependency is probably unnecessary and should be removed.

Please synchronize the dependencies with the upstream -git PKGBUILD. Some of them should be makedepends/optdepends instead of full dependencies.

https://github.com/wwmm/pulseeffects/blob/v5.0.0/PKGBUILD

Additional info:
* package version(s) 5.0.0-1
* Related:  FS#68928 , FS#68617

By the way, should the legacy 4.x package be reintroduced as pulseeffects4 for pulseaudio users?
(with dependencies synced to https://github.com/wwmm/pulseeffects/blob/pulseaudio-legacy/PKGBUILD )



This task depends upon

Comment by A. Bosch (progandy) - Monday, 25 January 2021, 13:49 GMT
pipewire-pulse could probably be an optdepend, but the package description should then make it clear that pipewire-pulse is required to apply effects to pulseaudio applications, something like

"Audio Effects for the PipeWire Sound Server (and Pulseaudio Applications)"
Comment by Harley (MrSelfDestruct) - Thursday, 28 January 2021, 20:34 GMT
I can confirm it crashes without pipewire-pulse and without gst-plugin-pipewire
Comment by Morfeo (M0Rf30) - Friday, 29 January 2021, 09:28 GMT
Please could you take a look at pulseeffects-git package as inspiration? It's battle-tested, especially for this 5.0.0 version and should fix this. It also suggests a better packaging approach, that split pulseeffects GTK application and pulseeffects gst plugins (for headless scenarios).
Comment by sp32 (Slayerproof32) - Saturday, 06 February 2021, 21:42 GMT
I can confirm that 5.0 crashes without pipewire for me as well. I will have to look into switching over from Pulse to pipewire at some point as it seems to have many benefits. Downgraded to 4.8.3-3 for the time being.
Comment by Philipp (hollunder) - Saturday, 06 March 2021, 09:19 GMT
For me this packages dependencies also caused issues, although in a different way.
See https://bugs.archlinux.org/task/68848
Comment by Jens G (Thah) - Wednesday, 17 March 2021, 09:12 GMT
I'd 'vote' for a legacy 'pulseeffects4' package.

Loading...