Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69390 - [hy] Missing dependency

Attached to Project: Community Packages
Opened by usao (usao) - Thursday, 21 January 2021, 06:41 GMT
Last edited by Morten Linderud (Foxboron) - Tuesday, 26 January 2021, 22:11 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Morten Linderud (Foxboron)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Dependency of python-clint has been replaced by python-colorama since 0.18.0. See https://github.com/hylang/hy/blob/master/NEWS.rst.
This task depends upon

Closed by  Morten Linderud (Foxboron)
Tuesday, 26 January 2021, 22:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.20.0-1
Comment by Alexander F. Rødseth (xyproto) - Friday, 22 January 2021, 18:22 GMT
Thanks for reporting. Please include the steps for how to reproduce the issue.
Comment by usao (usao) - Saturday, 23 January 2021, 13:47 GMT
Steps to reproduce:

Try to import hy in python or run hy directly:

Traceback (most recent call last):
File "/usr/bin/hy", line 8, in <module>
from hy.cmdline import hy_main
File "/usr/lib/python3.9/site-packages/hy/__init__.py", line 18, in <module>
from hy.models import HyExpression, HyInteger, HyKeyword, HyComplex, HyString, HyBytes, HySymbol, HyFloat, HyDict, HyList, HySet # NOQA
File "/usr/lib/python3.9/site-packages/hy/models.py", line 9, in <module>
from hy.errors import HyWrapperError
File "/usr/lib/python3.9/site-packages/hy/errors.py", line 12, in <module>
from colorama import Fore
ModuleNotFoundError: No module named 'colorama'

Loading...