Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69374 - nvme-cli 1.13-1 contains possible syntax errors in one of the package files

Attached to Project: Community Packages
Opened by Mike Cloaked (mcloaked) - Tuesday, 19 January 2021, 21:38 GMT
Last edited by Morten Linderud (Foxboron) - Tuesday, 19 January 2021, 21:53 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Morten Linderud (Foxboron)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: nvme-cli 1.13-1 has a possible problematic file installed.


Additional info:
* package version(s) nvme-cli 1.13-1
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce: Install nvme-cli 1.13-1, and when running dracut as part of a kernel install hook, during the pacman install of a kernel, the log contains:

(4/4) Updating linux-stable dracut initrd
/usr/lib/dracut/dracut.conf.d/70-nvmf-autoconnect.conf:install_items+="/usr/lib/udev/rules.d/70-nvmf-autoconnect.rules"

dracut: WARNING: <key>+=" <values> ": <values> should have surrounding white spaces!
dracut: WARNING: This will lead to unwanted side effects! Please fix the configuration file.

dracut: Executing: /usr/bin/dracut --zstd --early-microcode --mdadmconf --force /boot/initramfs-dracut-linux-stable.img --kver 5.10.9-1-stable

(This is a private build kernel)

Investigating further yields:
$ pacman -Qo /usr/lib/udev/rules.d/70-nvmf-autoconnect.rules
/usr/lib/udev/rules.d/70-nvmf-autoconnect.rules is owned by nvme-cli 1.13-1

And looking at the two files involved shows:

$ cat /usr/lib/dracut/dracut.conf.d/70-nvmf-autoconnect.conf
install_items+="/usr/lib/udev/rules.d/70-nvmf-autoconnect.rules"


$ cat /usr/lib/udev/rules.d/70-nvmf-autoconnect.rules
#
# nvmf-autoconnect.rules:
# Handles udev events which invoke automatically scan via discovery
# controller and connect to elements in the discovery log.
#
#

# Events from persistent discovery controllers or nvme-fc transport events
# NVME_AEN:
# type 0x2 (NOTICE) info 0xf0 (DISCOVERY_LOG_CHANGE) log-page-id 0x70 (DISCOVERY_LOG_PAGE)
ACTION=="change", SUBSYSTEM=="nvme", ENV{NVME_AEN}=="0x70f002",\
ENV{NVME_TRTYPE}=="*", ENV{NVME_TRADDR}=="*", \
ENV{NVME_TRSVCID}=="*", ENV{NVME_HOST_TRADDR}=="*", \
RUN+="/bin/systemctl --no-block start nvmf-connect@--device=$kernel\t--transport=$env{NVME_TRTYPE}\t--traddr=$env{NVME_TRADDR}\t--trsvcid=$env{NVME_TRSVCID}\t--host-traddr=$env{NVME_HOST_TRADDR}.service"

# nvme-fc transport generated events (old-style for compatibility)
ACTION=="change", SUBSYSTEM=="fc", ENV{FC_EVENT}=="nvmediscovery", \
ENV{NVMEFC_HOST_TRADDR}=="*", ENV{NVMEFC_TRADDR}=="*", \
RUN+="/bin/systemctl --no-block start nvmf-connect@--device=none\t--transport=fc\t--traddr=$env{NVMEFC_TRADDR}\t--trsvcid=none\t--host-traddr=$env{NVMEFC_HOST_TRADDR}.service"

So perhaps the suggested error from the dracut output could be fixed by a suitable edit of the files from nvme-cli?

This looks benign since the kernels concerned boot normally, but it is still worth fixing the files that generate the dracut error?
This task depends upon

Closed by  Morten Linderud (Foxboron)
Tuesday, 19 January 2021, 21:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.13-2

Loading...