Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69344 - [grub] Does not ship 915resolution

Attached to Project: Arch Linux
Opened by Maxim (mxfm) - Saturday, 16 January 2021, 07:33 GMT
Last edited by Christian Hesse (eworm) - Monday, 26 April 2021, 09:47 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: The grub package according to PKGBUILD (https://github.com/archlinux/svntogit-packages/blob/packages/grub/trunk/PKGBUILD#L172) should ship module - 915 resolution from grub-extras repo. However, the built package does not provide such module. Either the module should be compiled (and PKGBUILD fixed) or this module can be dropped from PKGBUILD.


Additional info:
* package version(s) 2:2.04-8
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

1. Install grub from official repo
2. pacman -Ql grub | grep resolution
This task depends upon

Closed by  Christian Hesse (eworm)
Monday, 26 April 2021, 09:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  in svn
Comment by Maxim (mxfm) - Saturday, 06 March 2021, 19:09 GMT
Update. It seems the issue was caused some time ago when 'bootstrap' script was introduced into grub configuration.

The presence of grub-extras modules is checked in autogen.sh. Previously it was called with configure in _build_grub-common_and_bios() where GRUB_CONTRIB is exported. Currently it is called in _prepare() as part of bootstrap.sh, but this happens before setting GRUB_CONTRIB variable. This means that when autogen.sh is executed, this variable is not set yet. I could fix this issue by moving export GRUB_CONTRIB to _prepare()
Comment by Christian Hesse (eworm) - Wednesday, 21 April 2021, 11:25 GMT
Do you move the export only or the copy commands as well? Can you provide a diff?
Comment by Christian Hesse (eworm) - Wednesday, 21 April 2021, 13:03 GMT
On the other hand... Given the little response to this bug report (no "me too!"), does it make sense to just drop this?
Comment by Maxim (mxfm) - Thursday, 22 April 2021, 04:52 GMT
I think the i915 module can be dropped (I have written this report not because I need it, I was just digging in grub-extras).
Comment by Christian Hesse (eworm) - Monday, 26 April 2021, 09:46 GMT
Just removed grub-extras from build.

Loading...