Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69318 - Linux-lts 5.4.89-1 breaks sound - Realtek ALC287

Attached to Project: Arch Linux
Opened by Darnell Keith (darnell) - Thursday, 14 January 2021, 00:36 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 08 February 2021, 08:16 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

linux-lts 5.4.89-1 breaks sound for Realtek ALC287 devices or Lenovo Yoga Duet 7i.
I'm new to arch so I'm not sure what logs to post. However, I'm using Arch because until now it was the only distro I've found to work. Downgrading the kernel to 5.4.88-1 has sound working again. But why? What's different?
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 08 February 2021, 08:16 GMT
Reason for closing:  No response
Comment by Doug Newgard (Scimmia) - Thursday, 14 January 2021, 00:49 GMT Comment by loqs (loqs) - Thursday, 14 January 2021, 01:02 GMT
5.4.89 contained 5 ALSA related commits [1]. I would suggest reverting those and seeing if you can still reproduce the issue.
If those are not the cause try bisecting between 5.4.88 and 5.4.89.

[1] https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.4.89
Comment by Hussam Al-Tayeb (hussam) - Thursday, 14 January 2021, 10:25 GMT
Try notifying the upstream developers, particularly Greg Kroah-Hartman on the LKML. I have asked numerous times for longer preview periods for the stable point releases to avoid such incidents.
Comment by Andreas Radke (AndyRTR) - Sunday, 31 January 2021, 12:36 GMT
Is it working again or any regression bug we can follow?
Comment by Darnell Keith (darnell) - Sunday, 31 January 2021, 19:18 GMT
No. And I doubt it will ever get fixed unless some developer with this sound card or related device makes some special kernel for us. This isn't just a problem on Arch but all distros, and it has been a known issue since June or July of last year. I'm still using Kernel 5.4.88-1-lts to keep sound.
Comment by Hussam Al-Tayeb (hussam) - Sunday, 31 January 2021, 19:32 GMT
File an upstream bug report with which kernel last worked and which broke.

Is this it? https://bugzilla.kernel.org/show_bug.cgi?id=208555
Comment by Hussam Al-Tayeb (hussam) - Sunday, 31 January 2021, 20:51 GMT
https://git.kernel.org/pub/scm/linux/kernel/git/stable/stable-queue.git/commit/?id=1889f9ac9f9eb7f91ffc22e607a2e3db3db2e72e
This is the list of patches that went into 5.4.89
Perhaps you can can revert the alsa ones individually and check which revert fixes the bug?
Comment by loqs (loqs) - Monday, 01 February 2021, 20:01 GMT
Attached source bundle for linux-lts 5.4.89 modified to use the git source and revert five commits for the ALSA subsystem.
If the issue is still present with this build you will need to bisect between the two releases.

Loading...