Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69313 - [pulseaudio] Since pulseaudio 14.1, my output switches to another not working

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Wednesday, 13 January 2021, 16:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Unconfirmed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 4
Private No

Details

Description: I noticed this bug right after pulseaudio was upgraded to 14.1. It switches every 2 minutes or so from my working output (LineOut) to my webcam one...

My fix was to downgrade to pulse audio 14.0.


Additional info:
pulseaudio 14.1-1

Steps to reproduce:
Just upgrade to pulseaudio 14.1. Launch a video (on youtube or anywhere else). One or two minutes later, output is switched to another one.

I got this error in my everything.log file:

Jan 13 17:24:55 fredo-arch-gnome pulseaudio[36594]: Doing resync
Jan 13 17:24:55 fredo-arch-gnome pulseaudio[36594]: Playback too far ahead (106244), drop source 20396
Jan 13 17:24:55 fredo-arch-gnome pulseaudio[36594]: Doing resync
Jan 13 17:24:55 fredo-arch-gnome pulseaudio[36594]: Playback too far ahead (15318), drop source 2940
Jan 13 17:24:56 fredo-arch-gnome pulseaudio[36594]: Playback too far ahead (11362), drop source 2180
Jan 13 17:24:58 fredo-arch-gnome pulseaudio[36594]: Doing resync
Jan 13 17:24:58 fredo-arch-gnome pulseaudio[36594]: Playback too far ahead (16586), drop source 3184
Jan 13 17:24:58 fredo-arch-gnome pulseaudio[36594]: Doing resync
Jan 13 17:24:58 fredo-arch-gnome pulseaudio[36594]: Playback too far ahead (7753), drop source 1488
Jan 13 17:24:59 fredo-arch-gnome pulseaudio[36594]: Playback too far ahead (5617), drop source 1076
This task depends upon

2021-01-17: A task closure has been requested. Reason for request: bug fixed
Comment by Frederic Bezies (fredbezies) - Wednesday, 13 January 2021, 16:40 GMT
Issue reported here or looking like this one: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/1096
Comment by Trit' (trit) - Friday, 15 January 2021, 08:05 GMT
Not fixed in the today’s update to 14.1-2, reported upstream: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/1096#note_766342
Comment by Frederic Bezies (fredbezies) - Friday, 15 January 2021, 10:52 GMT
Same for me. 14.1-2 is still broken. A way to fix this is to revert this commit: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/commit/254cb4bd1f0905270f77462d766c88bf39ccf8a5

Downgrading once again pulseaudio, libpulse and pulseaudio-bluetooth.
Comment by Sibo Dong (flyingpig) - Friday, 15 January 2021, 17:58 GMT
[Upstream has merged a fix to `master`][1], so I guess we just wait until it lands in `stable-14.x`.

[1]: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/468
Comment by Jesse Limerick (iontunnel) - Sunday, 17 January 2021, 01:06 GMT
Problem fixed in latest update

Loading...