Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69305 - [gcc] Missing Manual Pages

Attached to Project: Arch Linux
Opened by Peter Weber (hoschi) - Tuesday, 12 January 2021, 12:15 GMT
Last edited by freswa (frederik) - Friday, 11 February 2022, 18:31 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Giancarlo Razzolini (grazzolini)
freswa (frederik)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Hello!

Description:
The GCC includes the auto generated manual pages for C++. Most other hand written manuals are part of venerable `man-pages` including C, POSIX and Linux APIs. The manual pages of GCC C++ implemenation can be opened with "man C++Intro", "man std::vector", "man std::smart_ptr" and so on. The intro page states that there should also be more general category pages:

Namespace_std A listing of the contents of std::.
Namespace___gnu_cxx A listing of the contents of __gnu_cxx::.
Containers An introduction to container classes.
Sequences Linear containers.
Assoc_containers Key-based containers.
Iterator_types Programatically distinguishing iterators/pointers.
Intro_functors An introduction to function objects, or functors.
Arithmetic_functors Functors for basic math.
Binder_functors Functors which "remember" an argument.
Comparison_functors Functors wrapping built-in comparisons.
Func_ptr_functors Functors for use with pointers to functions.
Logical_functors Functors wrapping the Boolean operations.
Member_ptr_functor Functors for use with pointers to members.
Negation_functors Functors which negate their contents.
SGIextensions A list of the extensions from the SGI STL subset.

I cannot open them, with the exception of SGIextensions which is installed.

Additional info:
* package version(s): 10.2.0-4


Steps to reproduce:
1.) # pacman -S base-devel
2.) $ man Namespace_std
No manual entry for Namespace_std

I'm not sure if this a packaging or upstream issue.
Thank you
This task depends upon

Closed by  freswa (frederik)
Friday, 11 February 2022, 18:31 GMT
Reason for closing:  Works for me
Comment by freswa (frederik) - Thursday, 10 February 2022, 00:57 GMT
Is this still an issue with gcc 11.2.0-2 in [testing]?

Loading...