Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69288 - [catfish] Missing dep on xfconf

Attached to Project: Community Packages
Opened by roberto porcaro (porcaror) - Monday, 11 January 2021, 12:02 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 16 January 2021, 09:06 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
If xfconf is not installed the program doesn't work. But xfconf is not required as a dependency. My DE is Cinnamon so I had this problem Can you confirm this? In this case is it possible to have catfish working without that dependency?

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 16 January 2021, 09:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  catfish 4.16.0-3
Comment by Doug Newgard (Scimmia) - Monday, 11 January 2021, 12:29 GMT
So this is about catfish? What problem are you seeing?
Comment by Doug Newgard (Scimmia) - Thursday, 14 January 2021, 03:21 GMT
Ping?
Comment by roberto porcaro (porcaror) - Thursday, 14 January 2021, 09:35 GMT
Dear Doug,
sorry for the delay in my answer (I was really very busy at work). Before this version I didn't have xfconf installed and catfish was working. Now catfish works only if xfconf is installed (but it is not required in the list of catfish dependencies). Of course it's not really a problem but perhaps it might be convenient to explicitly say that xfconf is necessary to have catfish working.
In any case don't mind because it works.
Comment by Doug Newgard (Scimmia) - Saturday, 16 January 2021, 01:36 GMT
Ok, so we did establish that it's catfish and happened after an update, but we still got no description of the error or anything. Good bug reports always include what you're seeing, what change triggered the problem, including versions, and any logs you can find.

Loading...