Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69279 - [clang] Remove RPATH from installed files

Attached to Project: Arch Linux
Opened by Emil (xexaxo) - Sunday, 10 January 2021, 18:23 GMT
Last edited by Evangelos Foutras (foutrelis) - Tuesday, 08 February 2022, 01:19 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

By default, clang supports installation outside of /usr/lib. As such if force enables the cmake "INSTALL_RPATH" so the RPATH is embedded into the binaries and libraries. Since Arch uses the /usr/lib having the RPATH is not needed (and in some corner-cases wrong).

Please drop rpath by using
$ cmake -DCMAKE_SKIP_RPATH=TRUE ...


Additional info:
* package version(s)
11.0.1-1

Steps to reproduce:
1. Rebuild with `cmake -DCMAKE_SKIP_RPATH=TRUE ...`
2. Run any program which uses clang
3. Things just work
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Tuesday, 08 February 2022, 01:19 GMT
Reason for closing:  Implemented
Additional comments about closing:  clang 13.0.1-1
Comment by Emil (xexaxo) - Sunday, 30 January 2022, 20:33 GMT
Here's a patch I've been using for nearly one year. Hope it helps to move this forward.
Comment by Emil (xexaxo) - Monday, 31 January 2022, 00:14 GMT
v2 is using the _INSTALL_ variant, to avoid test failures.

Loading...