Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69276 - [cni-plugins] Unusable due to symlinks

Attached to Project: Community Packages
Opened by Tyler (SleepingShell) - Sunday, 10 January 2021, 17:20 GMT
Last edited by Morten Linderud (Foxboron) - Tuesday, 26 January 2021, 22:45 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Morten Linderud (Foxboron)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Some CNI plugins (Cilium in my case) mount the /opt/cni/bin directory in a container in order to provide networking functionality. However, due to this package putting the real binaries in /usr/lib/cni/bin and symlinking /opt/cni/bin, the binaries are unusable to the container.

Additional info:
* package version(s): 0.9.0-4

Steps to reproduce:
1. Install the cni-plugins package
2. Attempt to use the binaries under /opt/cni/bin
This task depends upon

Closed by  Morten Linderud (Foxboron)
Tuesday, 26 January 2021, 22:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.9.0-5
Comment by Morten Linderud (Foxboron) - Thursday, 14 January 2021, 17:40 GMT
Aaaahhhhhh for fuck sake

Loading...