Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69267 - Latest linux brings high power consumption in high refresh rates on navi graphics

Attached to Project: Arch Linux
Opened by Paulo Marcos (Myghi63) - Sunday, 10 January 2021, 02:17 GMT
Last edited by Jan Alexander Steffens (heftig) - Saturday, 23 January 2021, 23:50 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The latest linux kernel on my system makes my AMD Radeon RX 5500XT 8GB (gigabyte) draw 5 times more power on my 75Hz 1080p monitor (LG 24MK430) via HDMI while idling. On 60Hz, it draws about 3 Watt, while on 75Hz draws about 15 Watt. I also installed the latest linux-lts 5.4.87-1 package to test and it works really well, drawing about 3 Watt on 75Hz, but because of how this kernel version works, my system takes way more time to boot if compared to 5.10.5 kernel. Also I installed Gnome and KDE Plasma desktop environments and, while idling, I got the same results (I'm using xfce4 for reference, with xfwm4).

Additional info:
* package version(s)
Linux version 5.10.5.arch1-1 (linux-zen 5.10.5.arch1-1 also does the same)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
Install arch linux with the latest kernel on a system with high refresh rate monitor and AMD NAVI GPU. The graphics card will heat doing nothing.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Saturday, 23 January 2021, 23:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 5.10.9
Comment by Paulo Marcos (Myghi63) - Friday, 15 January 2021, 13:44 GMT
I tried all 5.10.X kernels and every single one makes my gpu heat doing nothing with an refresh rate above 60Hz.
Comment by Paulo Marcos (Myghi63) - Monday, 18 January 2021, 23:43 GMT
So I reported that to kernel bugzilla and there's already a patch waiting to be applied on 5.11 kernels. I'm requesting closure.
Comment by loqs (loqs) - Tuesday, 19 January 2021, 00:42 GMT
https://bugzilla.kernel.org/show_bug.cgi?id=211263 lists the code fix as a861736dae644a0d7abbca0c638ae6aad28feeb8 which is in 5.10-rc1+ so it was in 5.10.5.arch1-1 you experienced the issue with.
Comment by tgn-ff (tgn-ff) - Tuesday, 19 January 2021, 14:23 GMT
*Reverting* a861736dae644a0d7abbca0c638ae6aad28feeb8 is the fix. Here is the report on freedesktop: https://gitlab.freedesktop.org/drm/amd/-/issues/1407 The reporter closed the issue as fixed in 5.10.8, but I don't see the patch in this version. It seems it was just patched in their distro. Hopefully we won't have to wait until 5.11 for arch.
Comment by loqs (loqs) - Tuesday, 19 January 2021, 16:19 GMT
@tgn-ff thank you for the correction as you noted I had missed the fix was 4eec66c014e9a406d8d453de958f6791d05427e4 reverting a861736dae644a0d7abbca0c638ae6aad28feeb8
Comment by Jan Alexander Steffens (heftig) - Saturday, 23 January 2021, 23:50 GMT
This was fixed in 5.10.9 upstream.

Loading...