Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69249 - [gnuradio] gnuradio package installs gnuradio-companion, but not its dependencies

Attached to Project: Community Packages
Opened by pyfisch (pyfisch) - Friday, 08 January 2021, 10:27 GMT
Last edited by Antonio Rojas (arojas) - Friday, 08 January 2021, 10:29 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

There are two split packages gnuradio and gnuradio-companion. The former contains all files, the latter none. While the gnuradio packages includes the gnuradio-companion it is unusable because some dependencies are missing that are part of the gnuradio-companion package.

See file list for gnuradio:

* usr/bin/gnuradio-companion
* usr/share/applications/gnuradio-grc.desktop
* usr/share/gnuradio/grc/

On a basic install you will most likely lack at least python-cairo (prevents startup), python-pyqt5 and qwt (needed for waterfall display).

Additional info:
* package version(s): gnuradio 3.8.2.0-1

Steps to reproduce:

Install gnuradio, try to start the gnuradio-companion. An error message appears (see attached). If you install python-cairo and try to run actual programs you will encounter additional errors.

See also: #69243 (bug reported erroneously because I didn't realize that gnuradio installs gnuradio-companion)
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 08 January 2021, 10:29 GMT
Reason for closing:  Not a bug
Additional comments about closing:  That's the whole point of the gnuradio-companion package

Loading...