Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69247 - [xorg-server] Xorg crashed and dumped core

Attached to Project: Arch Linux
Opened by Saiki Kunio (kunio) - Friday, 08 January 2021, 02:58 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 21 April 2021, 11:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: Process Xorg crashed and dumped core.

<details><summary>Backtrace</summary>

systemd-coredump[701]: Process 484 (Xorg) of user 0 dumped core.
Stack trace of thread 484:
#0 0x00007fa473684615 raise (libc.so.6 + 0x3d615)
#1 0x00007fa47366d862 abort (libc.so.6 + 0x26862)
#2 0x0000564ce1b1e6ea OsAbort (Xorg + 0x14a6ea)
#3 0x0000564ce1b201b1 FatalError (Xorg + 0x14c1b1)
#4 0x0000564ce1b25e09 n/a (Xorg + 0x151e09)
#5 0x00007fa4736846a0 __restore_rt (libc.so.6 + 0x3d6a0)
#6 0x00007fa473684615 raise (libc.so.6 + 0x3d615)
#7 0x00007fa47366d862 abort (libc.so.6 + 0x26862)
#8 0x00007fa47366d747 __assert_fail_base.cold (libc.so.6 + 0x26747)
#9 0x00007fa47367cbf6 __assert_fail (libc.so.6 + 0x35bf6)
#10 0x0000564ce1a69870 n/a (Xorg + 0x95870)
#11 0x00007fa46d394fb9 glamor_init (libglamoregl.so + 0xcfb9)
#12 0x00007fa46d3f80fd n/a (modesetting_drv.so + 0x140fd)
#13 0x0000564ce1a4d40e AddGPUScreen (Xorg + 0x7940e)
#14 0x0000564ce1b59eb9 n/a (Xorg + 0x185eb9)
#15 0x0000564ce1b8f288 n/a (Xorg + 0x1bb288)
#16 0x0000564ce1b8f52b n/a (Xorg + 0x1bb52b)
#17 0x0000564ce1b3f435 InitInput (Xorg + 0x16b435)
#18 0x0000564ce1a0d798 n/a (Xorg + 0x39798)
#19 0x00007fa47366f152 __libc_start_main (libc.so.6 + 0x28152)
#20 0x0000564ce1a0e5de _start (Xorg + 0x3a5de)

Stack trace of thread 662:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa4728f6b80 n/a (intel_drv.so + 0xb0b80)
#2 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#3 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 667:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa47067b58c n/a (i965_dri.so + 0x55758c)
#2 0x00007fa47067ae08 n/a (i965_dri.so + 0x556e08)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 669:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa47067b58c n/a (i965_dri.so + 0x55758c)
#2 0x00007fa47067ae08 n/a (i965_dri.so + 0x556e08)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 660:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa4728f6b80 n/a (intel_drv.so + 0xb0b80)
#2 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#3 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 661:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa4728f6b80 n/a (intel_drv.so + 0xb0b80)
#2 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#3 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 668:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa47067b58c n/a (i965_dri.so + 0x55758c)
#2 0x00007fa47067ae08 n/a (i965_dri.so + 0x556e08)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 691:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 692:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 695:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 685:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 693:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 684:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 688:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 687:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 689:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 686:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 699:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 696:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 670:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa47067b58c n/a (i965_dri.so + 0x55758c)
#2 0x00007fa47067ae08 n/a (i965_dri.so + 0x556e08)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 697:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 690:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 698:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)

Stack trace of thread 694:
#0 0x00007fa47353c6a2 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf6a2)
#1 0x00007fa45ed1e52c n/a (radeonsi_dri.so + 0x4ed52c)
#2 0x00007fa45ed1ccf8 n/a (radeonsi_dri.so + 0x4ebcf8)
#3 0x00007fa4735363e9 start_thread (libpthread.so.0 + 0x93e9)
#4 0x00007fa473747293 __clone (libc.so.6 + 0x100293)
</details>

**Coredump** files: [Xorg.coredump.zip](https://drive.google.com/file/d/13bhfoTa4yo1aT8rbViauHy7Yjz1Pv-sq/view?usp=sharing)

Additional info:
* package version(s):
- xorg-server 1.20.10-3
- lightdm 1:1.30.0-4
- xfwm4 4.16.0-2
- kernel: linux-lts 5.4.87-1
* config and/or log files etc:
- I'm most using default config. Maybe I misremember something.
- Log files: Xorg.0.log
* link to upstream bug report, if any: none

Steps to reproduce: Using it maybe.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 21 April 2021, 11:54 GMT
Reason for closing:  Fixed
Comment by Saiki Kunio (kunio) - Wednesday, 20 January 2021, 10:06 GMT
The crash has been happened daily for me lately.
Comment by SimpleTechGuy (SimpleTechGuy) - Thursday, 01 April 2021, 22:19 GMT
Getting very similar crash as well.. Sometimes multiple times per day. Same versions of xorg & lightdm as mentioned in report; Main difference is i'm using 4.19 kernel and compiz. Issue began for me on 12.28.20. I usually perform updates monthly so it could have appeared in an update released around that time.. Willing to provide more information if needed.
Comment by Cedric (Cbhihe) - Wednesday, 14 April 2021, 20:51 GMT
Maybe related, coredumps started happening for me 5 days ago whenever I try to issue the terminal cmd: `xinput --disable <device_name>` where my device is the touchpad on a Dell XPS machine .
For me the trace is always:

systemd-coredump[36090]: Process 31812 (Xorg) of user 1000 dumped core.

Stack trace of thread 31812:
#0 0x00007f27e637def5 raise (libc.so.6 + 0x3cef5)
#1 0x00007f27e6367862 abort (libc.so.6 + 0x26862)
#2 0x000055e2520e46ea OsAbort (Xorg + 0x14a6ea)
#3 0x000055e2520e61b1 FatalError (Xorg + 0x14c1b1)
#4 0x000055e2520ebe09 n/a (Xorg + 0x151e09)
#5 0x00007f27e637df80 __restore_rt (libc.so.6 + 0x3cf80)
#6 0x00007f27d1486fd0 libinput_device_config_send_events_get_modes (libinput.so.10 + 0x11fd0)
#7 0x00007f27d8014139 n/a (libinput_drv.so + 0x9139)
#8 0x00007f27d8018a19 n/a (libinput_drv.so + 0xda19)
#9 0x000055e2520a9a87 XIChangeDeviceProperty (Xorg + 0x10fa87)
#10 0x000055e2520aa6af n/a (Xorg + 0x1106af)
#11 0x000055e251fd4195 n/a (Xorg + 0x3a195)
#12 0x00007f27e6368b25 __libc_start_main (libc.so.6 + 0x27b25)
#13 0x000055e251fd45de _start (Xorg + 0x3a5de)

The X crash kills my gdm user session and everything in it, and I find myself staring at a user session login screen.
Everything else is functional on my host running latest Arch.

The xorg-xinput version is 1.6.3-2. X-crashes started with following updates (gdm + linux kernel/headers):
(from /var/log/pacman.log):
- [2021-04-09T08:29:29+0200] [ALPM] upgraded linux (5.11.11.arch1-1 -> 5.11.12.arch1-1)
- [2021-04-09T08:29:30+0200] [ALPM] upgraded gdm (3.38.2.1-1 -> 40.0-1)
Comment by SimpleTechGuy (SimpleTechGuy) - Friday, 16 April 2021, 14:46 GMT
I noticed for me the issue was directly related to an option within my remote access software to blank physical screen when connected. At this point not sure if the problem I experienced is with the remote access software or with Xorg. Disabling the screen blanking seems to have fixed the problem for now.
Comment by Laurent Carlier (lordheavy) - Friday, 16 April 2021, 15:12 GMT
@Cedric

This should be fixed with xf86-input-libinput-1.0.1-1
Comment by Cedric (Cbhihe) - Friday, 16 April 2021, 15:39 GMT
@kunio and @SimpleTechGuy: sorry for the noise, guys.
I thought my issue was related but it's not apparently. My issue is a long-standing but until then silent bug in `xf86-input-libinput` as per the issue I opened on the Xorg gitlab repo (merged into previous bug report: https://gitlab.freedesktop.org/xorg/driver/xf86-input-libinput/-/issues/36).

@lordheavy:
Thanks for yr confirmation. I am indeed running only v1.0.0-1 of `xf86-input-libinput`. Funny thing is the bug only concerns touchpad disabling/enabling. One could call it an "orphan-bug" (since it must be affecting very very few *nix users).

/CLOSE/

Loading...