Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69228 - pipewire 0.3.19-1 some USB cards don't work anymore due to inconsistency in ACP profiles

Attached to Project: Arch Linux
Opened by Paulo Matias (thotypous_) - Tuesday, 05 January 2021, 22:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Unconfirmed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 4
Private No

Details

After upgrading from pipewire 0.3.18-1 to 0.3.19-1, a Behringer USB sound interface stopped working. Checking pavucontrol or painfo shows that only the "Off" profile is now available for the card.


Description:

Pipewire 0.3.19-1 contains new entries in the /usr/lib/udev/rules.d/90-pipewire-alsa.rules file that were not present in version 0.3.18-1. For example, the following entry was not present before 0.3.19-1:

ATTRS{idVendor}=="08bb", ATTRS{idProduct}=="2902", ENV{ACP_PROFILE_SET}="behringer-umc22.conf"

The ACP profile files are currently removed from the pipewire package by the PKGBUILD (see https://github.com/archlinux/svntogit-packages/blob/c2d2b1d4327471d17e98c55980df224a31499a6d/trunk/PKGBUILD#L83-L84), because the profiles from the pulseaudio package (installed to /usr/share/pulseaudio/alsa-mixer/profile-sets) are used instead.

However, this causes a problem, since the pipewire project will not necessarily be in sync with pulseaudio project regarding ACP profile files. For instance, the pulseaudio package does not contain behringer-umc22.conf.


Workaround:

Download https://gitlab.freedesktop.org/pipewire/pipewire/-/raw/master/spa/plugins/alsa/mixer/profile-sets/behringer-umc22.conf to /usr/share/alsa-card-profile/mixer/profile-sets


Additional info:
* package version(s): 0.3.19-1
* config and/or log files etc.: nothing relevant in journald logs
* link to upstream bug report, if any: none

Steps to reproduce:

1) plug a Behringer USB sound interface
2) try to record or reproduce sound from the Behringer USB sound interface
This task depends upon

2021-01-15: A task closure has been requested. Reason for request: Fixed by alsa-card-profiles-14.1-2
Comment by Matthias Berse (f0rdprefect) - Sunday, 10 January 2021, 09:09 GMT
Tried the workaround by just downloading and saving the .conf. After that the output would show up again, but I still would get no input. Downgraded to 0.3.18-1 for now...
Comment by Paulo Matias (thotypous_) - Sunday, 10 January 2021, 22:27 GMT
@f0rdprefect Which Profile were you using (Configuration tab in pavucontrol) with the workaround? Here I'm using "Analog Stereo Output + Analog Mono Input" to record from XLR.
Comment by Matthias Berse (f0rdprefect) - Tuesday, 12 January 2021, 20:36 GMT
None of the profiles in 0.3.19-1 results in an input device selectable in gnome sound settings. Maybe it is working sorts off, but I suspect at least some problems. I could select it as input in teams... Yeah I know but that is most important for that sound device now. Any pointers what to check / look for? BTW in 0.3.18-1 I can select `Analog Stereo Duplex` in pavucontrol and `Analog Input PCM2902 Audio Codec` in gnome sound settings. My Behringer device is a XENYX302USB -- Bus 002 Device 004: ID 08bb:2902 Texas Instruments PCM2902 Audio Codec
Comment by Kevin (nivekuil) - Friday, 15 January 2021, 01:21 GMT Comment by Paulo Matias (thotypous_) - Friday, 15 January 2021, 01:41 GMT
Fixed by alsa-card-profiles-14.1-2
Comment by Matthias Berse (f0rdprefect) - Friday, 15 January 2021, 09:18 GMT
The profile is there now. However I still cannot select an input in the gnome sound settings. I can with 0.3.18-1... If i edit out the udev rule for the USB device everything is back to the behavior in 0.3.18. The question is how to change the behringer-umc22.conf so it works also for the gnome sound settings. BTW also tried the XFCE4 mixer which has the same behavior as the gnome mixer.

Loading...