Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69188 - [grafana-zabbix] Plugin not working for latest version 4.1.1

Attached to Project: Community Packages
Opened by Nigel Kukard (nkukard) - Sunday, 03 January 2021, 09:38 GMT
Last edited by Morten Linderud (Foxboron) - Sunday, 17 January 2021, 15:09 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Florian Pritz (bluewind)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:

First off, thankyou so much for your work on this package, it is really greatly appreciated!

However it looks like from around 4.0 or so, there is binary required to be built an the plugin directory layout looks different compared to the official.


Additional info:
* package version(s): 4.0+

* config and/or log files etc.

t=2021-01-03T09:21:51+0000 lvl=dbug msg="Querying for data source via SQL store" logger=datasources id=1 orgId=1
t=2021-01-03T09:21:51+0000 lvl=eror msg="Plugin unavailable" logger=context userId=2 orgId=1 uname=nkukard error="Plugin unavailable"
t=2021-01-03T09:21:51+0000 lvl=eror msg="Request Completed" logger=context userId=2 orgId=1 uname=nkukard method=POST path=/api/datasources/1/resources/zabbix-api status=503 remote_addr=[redacted] time_ms=5 size=32 referer=https://[redacted]/datasources/edit/1/
t=2021-01-03T09:21:51+0000 lvl=dbug msg="Querying for data source via SQL store" logger=datasources id=1 orgId=1
t=2021-01-03T09:21:51+0000 lvl=eror msg="Plugin unavailable" logger=context userId=2 orgId=1 uname=nkukard error="Plugin unavailable"


* link to upstream bug report, if any


https://github.com/alexanderzobnin/grafana-zabbix/issues/1022
https://github.com/alexanderzobnin/grafana-zabbix/issues/1054
https://github.com/alexanderzobnin/grafana-zabbix/issues/1107



Steps to reproduce:

Install grafana, install grafana-zabbix. Enable the grafana-zabbix plugin ID to be loaded unsigned.

Setup a datasource.


Unpacking the official zip works 100%...
https://github.com/alexanderzobnin/grafana-zabbix/releases/download/v4.1.1/alexanderzobnin-zabbix-app-4.1.1.zip


I'd suggest building as upstream does and packaging the result.
This task depends upon

Comment by Florian Pritz (bluewind) - Saturday, 23 January 2021, 15:49 GMT
Please test grafana-zabbix 4.1.1-2. The plugin is now built just like upstream builds it and it seems to work fine for me.

Note that you will still need to allow it to be loaded unsigned by adding `allow_loading_unsigned_plugins = alexanderzobnin-zabbix-datasource` to the `[plugins]` section in the config. (This remark is mostly for anyone else reading this report)

Edit: Thank you for the detailed bug report!

Loading...