Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69091 - [xfce4-power-manager] .xsession-errors

Attached to Project: Arch Linux
Opened by Robert (robson) - Thursday, 24 December 2020, 15:48 GMT
Last edited by Evangelos Foutras (foutrelis) - Tuesday, 26 January 2021, 03:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

** (xfce4-power-manager:652): WARNING **: 16:37:37.371: Failed to get name owner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.xfce.PowerManager': no such name

(xfce4-power-manager:652): libnotify-WARNING **: 16:37:38.543: Failed to connect to proxy

(xfce4-power-manager:652): GLib-GObject-WARNING **: 16:37:38.550: ../glib/gobject/gsignal.c:2613: signal 'Changed' is invalid for instance '0x55ff53d33480' of type 'GDBusProxy'

(xfce4-power-manager:652): xfce4-power-manager-WARNING **: 16:37:38.563: could not map keysym 1008ffa8 to keycode

** (xfce4-power-manager:652): WARNING **: 16:37:38.566: No outputs have backlight property

(xfce4-power-manager:652): xfce4-power-manager-WARNING **: 16:37:38.731: Failed to get keyboard max brightness level : GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: Brak interfejsu „org.freedesktop.UPower.KbdBacklight” w obiekcie w ścieżce /org/freedesktop/UPower/KbdBacklight
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Tuesday, 26 January 2021, 03:50 GMT
Reason for closing:  Upstream
Additional comments about closing:  Upstream has closed this as "Not a bug"
Comment by Robert (robson) - Thursday, 24 December 2020, 23:30 GMT
At the moment there is only one sensible solution, you just have to enter the session/running programs, and uncheck the power-manager positions.
Comment by Evangelos Foutras (foutrelis) - Friday, 25 December 2020, 07:28 GMT
Is "Power Manager" enabled if you go to "Settings" -> "Session and Startup" and look at the "Application Autostart" pane?
Comment by Robert (robson) - Friday, 25 December 2020, 12:35 GMT
I currently have it turned off
https://i.postimg.cc/y8wGDQbq/xfce4-power-manager.png
But when I turn it on there are errors as above.
Comment by Evangelos Foutras (foutrelis) - Saturday, 26 December 2020, 08:40 GMT
Seems these warnings are now visible because xfce4-power-manager doesn't daemonize anymore.

Poked upstream to see if there's anything that can be done: https://gitlab.xfce.org/xfce/xfce4-power-manager/-/issues/105
Comment by Richard Lister (bnzmnzhnz) - Monday, 28 December 2020, 17:41 GMT
I encountered this running xfce4-power-manager from xinitrc, as the process no longer daemonizes by default, and blocks the script as a foreground process. Adding new --daemon option solves this issue.

See https://gitlab.xfce.org/xfce/xfce4-power-manager/-/merge_requests/3/diffs

Loading...