Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69055 - [systemd] GDM no longer appears automatically after updating to systemd 247.2-1

Attached to Project: Arch Linux
Opened by Doğukan Korkmaztürk (dogukan) - Monday, 21 December 2020, 15:23 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 21 April 2021, 11:49 GMT
Task Type Bug Report
Category Packages: Core
Status Assigned
Assigned To Jan Alexander Steffens (heftig)
Christian Hesse (eworm)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 8
Private No

Details

Description:
After updating to systemd 247.2-1, GDM login screen no longer appears automatically even though gdm.service is enabled through systemctl. I think the service starts because a simple workaround of switching to another terminal using Ctrl+Alt+F2 and switching back to GDM using Ctrl+Alt+F1 makes the login screen appear. It is just not displayed automatically after booting the system.

I have an AMD Vega 64 graphics card and I use mesa and amdgpu. My GDM configuration should be using Wayland. I have not tried it using X.

It seems like there are other people having the same problem: https://www.reddit.com/r/archlinux/comments/kfmbhx/after_upgrading_to_systemd_24721_gnome_login/.

I see these two lines when I run journalctl -p 3 -xb

Dec 21 08:26:15 ArchDesk gnome-session-binary[607]: Unrecoverable failure in required component org.gnome.Shell.desktop
Dec 21 08:26:28 ArchDesk gdm-password][1436]: gkr-pam: unable to locate daemon control file

Additional info:
* package version(s): systemd 247.2-1, gdm 3.38.2.1-1, mesa 20.3.1-1, linux 5.9.14.arch1-1
This task depends upon

Comment by Bario (barmadrid) - Monday, 21 December 2020, 23:31 GMT
I don't have this issue and I have the same GPU and packages installed!
Comment by Doğukan Korkmaztürk (dogukan) - Tuesday, 22 December 2020, 13:37 GMT
It may not be related to hardware. As I said it started after systemd upgrade. Just wanted to give as much information as possible.
Comment by Alesh (alkazar79) - Wednesday, 23 December 2020, 00:09 GMT
I am seeing this same problem, but it seems inconsistent, sometimes installing the affected package versions doesn't cause problems, and other times it does.

I am using the Nvidia proprietary drivers. I tried downgrading the drivers, but that had no effect.

It appears that the combination of systemd 247.2-1 and libseccomp 2.5.1-2 is the cause. Downgrading either of those packages seems to fix it.

I was able to reproduce with lightdm and gdm. It appears that Xorg is actually failing.
Log attached. Note that the log is taken from GamerOS (an Arch Linux derived distro), but I was also able to reproduce on an Arch Linux machine.

According to the log, Xorg is not finding the nvidia driver.

Strangely, the issue does not manifest until you reboot for the second time after installing the affected systemd and libseccomp packages.
Also, restarting lightdm or gdm manually from a tty works.
Comment by Jaap (Mushoz) - Saturday, 02 January 2021, 16:56 GMT
Exact same issue here with very similar logs, the most important part being:

Fatal server error:
[ 3.724] (EE) no screens found(EE)
[ 3.724] (EE)

I have Arch installed on 4 different machines, and this issue appears on 3 of them. The issue appears on:

Desktop running AMD Ryzen 5 3600 with Vega VII GPU
Desktop running AMD Ryzen 7 1800x with 5700XT
Laptop running AMD 4800u with Vega 8 iGPU

This issue does NOT happen on this laptop:

Intel 5200u with iGPU + nVidia 940m running proprietary drivers with switchable graphics.

The workaround to switch TTY and back again mentioned in the original post also works on all 3 machines having the issue, but it's an annoying workaround that shouldn't be needed.
Comment by Jaap (Mushoz) - Saturday, 02 January 2021, 17:06 GMT
Setting the debug variable for gdm to "true" and rebooting to reproduce the issue, gives me the following log when grepping journalctl on "gdm".
   gdm.log (363.7 KiB)
Comment by Christopher Snowhill (kode54) - Friday, 08 January 2021, 22:54 GMT
Funny journal excerpt now too:
Comment by Christopher Snowhill (kode54) - Friday, 08 January 2021, 22:55 GMT
Can't attach on edit. Here it is.
Comment by Alesh (alkazar79) - Saturday, 09 January 2021, 00:37 GMT
I was actually able to resolve the issue completely for lightdm using this from the Arch wiki:
https://wiki.archlinux.org/index.php/LightDM#LightDM_does_not_appear_or_monitor_only_displays_TTY_output
Comment by Christopher Snowhill (kode54) - Saturday, 09 January 2021, 05:47 GMT
Similarly, you may also join the ranks of many who add their gpu drivers to mkinitcpio.conf in the MODULES array.
Comment by Doğukan Korkmaztürk (dogukan) - Sunday, 10 January 2021, 13:17 GMT
Adding amdgpu to MODULES array seems like fixes the issue.
Comment by Jacob Henner (JacobHenner) - Sunday, 07 February 2021, 00:33 GMT
Experiencing this with Ryzen graphics.
Comment by bbo2adwuff (bbo2adwuff) - Wednesday, 24 February 2021, 09:55 GMT
I experienced the same problem today. And Ctrl+Alt+F2 and switching back to GDM using Ctrl+Alt+F1 was a workaround. But for me it seemed to be an issue with the /var/lib/gdm/.config/monitors.xml.

Does it help for anyone here after trying following?
cp ~/.config/monitors.xml /var/lib/gdm/.config/
Comment by Doğukan Korkmaztürk (dogukan) - Wednesday, 24 February 2021, 18:54 GMT
I tried cp ~/.config/monitors.xml /var/lib/gdm/.config/ but it didn't help
Comment by bbo2adwuff (bbo2adwuff) - Wednesday, 24 February 2021, 20:46 GMT
hmm confusing, I was able restart normally after coping monitors.xml.
But now after rebooting again and an external monitor connected I get almost the same error again.
Now see an aditional message:
snd_hda_codec_hdmi hdaudioC0D2: Monitor plugged-in, Failed to power up codec ret=[-13]
Comment by Vitali Malyshkin (vitalyam13gmail.com) - Friday, 19 March 2021, 19:03 GMT
Does anybody know how to fix it? I have this bug on Lenovo laptop with Intel CPU and discrete gpu by NVIDIA.
Comment by Andrew Davis (dandrew) - Sunday, 21 March 2021, 07:15 GMT
I'm seeing the same thing. Once i could get a shell i strace'd the gdm process, then swapped back to gdm's tty and it came up.

Output here: https://pastebin.com/CF4s1YHp

Basically it's stuck at `restart_syscall(<... resuming interrupted read ...>) = 1` till i switch back to the gdm tty

My hardware is a Dell XPS, kaby lake i7 with integrated Intel graphics.

Let me know if/how i can help and what sort of additional information can assist

edit: Update. I have both linux and linux-lts installed. This does NOT occur when booting the LTS kernel

Loading...