Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69049 - [guvcview] wants libilbc.so.2, but libilbc.so.3 is installed

Attached to Project: Community Packages
Opened by Andrej Podzimek (andrej) - Monday, 21 December 2020, 09:05 GMT
Last edited by Antonio Rojas (arojas) - Monday, 21 December 2020, 11:03 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: Description: guvcview requires libilbc.so.2 and so do attempts to build guvcview or guvcview-git.

Additional info:
* package version(s)
libilbc 3.0.3-1
guvcview 2.0.6-5
* config and/or log files etc.
Starting guvcview:
guvcview: error while loading shared libraries: libilbc.so.2: cannot open shared object file: No such file or directory
Building guvcview:
/usr/bin/ld: warning: libilbc.so.2, needed by /usr/bin/../lib64/gcc/x86_64-pc-linux-gnu/10.2.0/../../../../lib64/libavcodec.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: /usr/bin/../lib64/gcc/x86_64-pc-linux-gnu/10.2.0/../../../../lib64/libavcodec.so: undefined reference to `WebRtcIlbcfix_DecodeImpl'
/usr/bin/ld: /usr/bin/../lib64/gcc/x86_64-pc-linux-gnu/10.2.0/../../../../lib64/libavcodec.so: undefined reference to `WebRtcIlbcfix_InitEncode'
/usr/bin/ld: /usr/bin/../lib64/gcc/x86_64-pc-linux-gnu/10.2.0/../../../../lib64/libavcodec.so: undefined reference to `WebRtcIlbcfix_InitDecode'
/usr/bin/ld: /usr/bin/../lib64/gcc/x86_64-pc-linux-gnu/10.2.0/../../../../lib64/libavcodec.so: undefined reference to `WebRtcIlbcfix_EncodeImpl'
* link to upstream bug report, if any
N/A

Steps to reproduce: Start guvcview.
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 21 December 2020, 11:03 GMT
Reason for closing:  Not a bug
Additional comments about closing:  You are not using the official ffmpeg package

Loading...