Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#69014 - [firefox] No sound with Jack Audio sound server since FF84 upgrade

Attached to Project: Arch Linux
Opened by Turbo B (Turbo) - Thursday, 17 December 2020, 10:51 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 04 May 2021, 12:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


Since the upgrade to FF84 there is no more automatic connection in Jack Audio Sound Server(no Pulse Audio on my machine), have to do it manually ...

Additional info:
* package version(s): FireFox 84.0

Steps to reproduce: Play a video on the web..
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 04 May 2021, 12:01 GMT
Reason for closing:  Fixed
Comment by Turbo B (Turbo) - Thursday, 17 December 2020, 13:26 GMT
I turned off Jack to see if sound would play with Alsa and same issue ..
Comment by Niklas Reppel (parkellipsen) - Sunday, 31 January 2021, 15:42 GMT
Same here, Jack-only installation, have to connect manually. Especially annoying because most players create a new Jack client
when you pause/resume, or after an ad, so you can really only connect WHILE the actual video is running.

Other browsers use alsa directly, and the alsa-jack plugin works like a charm nowadays.

Firefox 83 still connected automatically to the system ports ... maybe it was removed in the wake of FS#52183 ?
Comment by Turbo B (Turbo) - Wednesday, 03 February 2021, 12:14 GMT
As workaround i run a script at boot using jack-matchmaker:

jack-matchmaker \
'Firefox:AudioStream_\d+_out_0' 'system:playback_1' \
'Firefox:AudioStream_\d+_out_1' 'system:playback_2'

it works very well but it's a workaround...
Comment by Zoë Sparks (tenfoxes) - Saturday, 06 February 2021, 21:26 GMT
I have the same issue. I wonder if the bug ultimately lies with upstream, though.
Comment by Angelo Haller (szanni) - Friday, 12 March 2021, 20:09 GMT
As this issue persists in FF86 I did some digging. There is an upstream commit disabling jack auto connect:
It very much seems like the patch and this issue are related.
I use jack_control to start the jack server as described in the Arch Wiki. I guess some option has to be set to re-enable auto port connect? I found a few options in jack_control, but to no avail:

jack_control ips netmanager auto-connect 1
jack_control ips netadapter auto-connect 1
jack_control eps self-connect-mode ' '
Comment by Turbo B (Turbo) - Saturday, 13 March 2021, 09:10 GMT
"This patch adds a perf to disable auto jack port connection. This is useful if the user of the lib wants to coordinate connection management themselves, for example linking into a mixing app rather than straight to audio_out." the dev says ... I think this is not a good approach. I think it's better that FF links straight to audio_out and the user change by hand the connection to link to a mixing app when need is...
Angelo, those Jack_control commands are not useful in this case.
Comment by Angelo Haller (szanni) - Saturday, 13 March 2021, 17:00 GMT
Thanks Turbo, I was aware that the commands did nothing. Just thought of documenting my trials.

I decided to escalate this issue upstream, as this looks a defect in Firefox itself. If anyone has anything to add, here is the upstream ticket:

Comment by Angelo Haller (szanni) - Saturday, 13 March 2021, 22:36 GMT
I just built Firefox from the latest HG tree (~FF88) where the problem seems to be resolved. At least for me.
So I installed `firefox-developer-edition` (FF87) from the repos, which works for me as well. Maybe somebody can confirm. Or is this related to some extension?
Comment by Turbo B (Turbo) - Sunday, 14 March 2021, 08:39 GMT
Angelo, `firefox-developer-edition` (FF87) works for me as well!
Comment by Jan Alexander Steffens (heftig) - Wednesday, 21 April 2021, 11:26 GMT
Is this solved in firefox now?