Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69008 - [spectacle] qt5-tools not required

Attached to Project: Arch Linux
Opened by Rafael Fryer (squidink7) - Wednesday, 16 December 2020, 22:37 GMT
Last edited by Antonio Rojas (arojas) - Wednesday, 16 December 2020, 23:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Much like the recently fixed kdeconnect package, spectacle has qt5-tools listed as a dependency when it is not required to run the program. I verified this by using pacman -Rdd on qt5-tools and spectacle still functioned as intended. Please remove qt5-tools from the dependency list for spectacle as it is a very large package to be installed unnecessarily.

Additional info:
* relevant as of spectacle version 20.12.0-1

Steps to reproduce:
install spectacle
see qtcreator and other utilities for making qt5 applications installed
This task depends upon

Closed by  Antonio Rojas (arojas)
Wednesday, 16 December 2020, 23:02 GMT
Reason for closing:  Not a bug
Additional comments about closing:  check org.kde.spectacle.desktop

Loading...