Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#69000 - [gdb] depends on libboost_regex

Attached to Project: Arch Linux
Opened by Andrey Suvalov (Palyashuk) - Wednesday, 16 December 2020, 09:40 GMT
Last edited by Antonio Rojas (arojas) - Wednesday, 16 December 2020, 11:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After updating boost package via pacman to 1.75 gdb does't work.
Research showed that gdb also depends on libboost_regex:

ldd /usr/bin/gdb
...
libboost_regex.so.1.72.0 => not found
...
But it is not added in dependency list for gdb

Steps to reproduce:
Update boost libs via pacman
Try to run gdb
This task depends upon

Closed by  Antonio Rojas (arojas)
Wednesday, 16 December 2020, 11:30 GMT
Reason for closing:  Not a bug
Comment by Jelle van der Waa (jelly) - Wednesday, 16 December 2020, 09:50 GMT
Which gdb? It should be fine:

[jelle@t14][~]%ldd /usr/bin/gdb | grep boost
libboost_regex.so.1.75.0 => /usr/lib/libboost_regex.so.1.75.0 (0x00007faefd6bd000)
[jelle@t14][~]%pacman -Q gdb
gdb 10.1-4
Comment by Allan McRae (Allan) - Wednesday, 16 December 2020, 10:05 GMT
Use "readelf -d" and not ldd. If it probably not gdb that is the issue, and something you have replaced in the dependency chain.
Comment by Andrey Suvalov (Palyashuk) - Wednesday, 16 December 2020, 11:00 GMT
Yes, you are right so sorry, that was my bad. Thanks for your time

Loading...