AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#68997 - "remote: error: maximum blob size (250.00KiB) exceeded" when pushing a file that is 250.8KiB

Attached to Project: AUR web interface
Opened by Kyle Devir (QuartzDragon) - Wednesday, 16 December 2020, 01:12 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Sunday, 27 December 2020, 23:26 GMT
Task Type Bug Report
Category Backend
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Medium
Priority Normal
Reported Version 4.7.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

This had to be a misconfiguration or something...

I was attempting to update the linux-pds package today, and got this wonderfully confusing error.

The `config` file is 250.8KiB, and thus triggered this error...

This break pushing any commits greater than 250KiB... which would include some patches that can easily exceed that weird limit.

Terminal output:

```
==> Retrieving sources...
-> Found config
-> Found 0005-v5.10_undead-pds099o.patch
-> Found 0005-undead-glitched-pds.patch
==> Generating checksums for source files...
[master 4922ad6] 5.10.1.arch1
5 files changed, 216 insertions(+), 121 deletions(-)
rename 0005-v5.9_undead-pds099o.patch => 0005-v5.10_undead-pds099o.patch (99%)
delete mode 100644 sphinx-workaround.patch
Enumerating objects: 10, done.
Counting objects: 100% (10/10), done.
Delta compression using up to 6 threads
Compressing objects: 100% (6/6), done.
Writing objects: 100% (6/6), 71.89 KiB | 6.54 MiB/s, done.
Total 6 (delta 3), reused 0 (delta 0), pack-reused 0
remote: error: The following error occurred when parsing commit
remote: error: 4922ad65bbe69bb6adff02fc818dbab863975e28:
remote: error: maximum blob size (250.00KiB) exceeded
remote: error: hook declined to update refs/heads/master
To ssh://aur.archlinux.org/linux-pds.git
! [remote rejected] master -> master (hook declined)
error: failed to push some refs to 'ssh://aur.archlinux.org/linux-pds.git'
```
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Sunday, 27 December 2020, 23:26 GMT
Reason for closing:  Fixed
Comment by Eli Schwartz (eschwartz) - Wednesday, 16 December 2020, 01:32 GMT
  • Field changed: Severity (Critical → Medium)
Oh yes, clearly very critical bug to have a configured limit perform as intended. I'm not sure why this is confusing? Disappointing, sure. But it's pretty obvious what this means.

If you have a 250KiB+ size patch file, you're doing something very wrong.

Kernel configs are I think the only thing that ever runs close to the limits, yet remains valid to upload to the AUR. It's very much the minority of packages.

The size of a kernel .config slowly creeps up. We probably need to bump the limit as part of housekeeping. But it's hardly a misconfiguration to have a limit.
Comment by Kyle Devir (QuartzDragon) - Wednesday, 16 December 2020, 01:46 GMT
250KiB is just too small. What if there are shipped patchsets that exceed this limit?
Comment by Kyle Devir (QuartzDragon) - Wednesday, 16 December 2020, 23:28 GMT
As a stopgap, I'm just going to compress the config file, because I have no choice right now... *shrug*
Comment by Levente Polyak (anthraxx) - Wednesday, 23 December 2020, 00:53 GMT
Can confirm this is an issue for kernel packages. This currently denies me from updating the linux-hardened-git package in the AUR as the kconfig exceedts the limit now. Would be neat to get this raised.
Comment by Leonidas Spyropoulos (inglor) - Wednesday, 23 December 2020, 07:25 GMT
Can't raise PRs against Archlinux GitLab yet but something like this patch would solve it.
Comment by Sven-Hendrik Haase (Svenstaro) - Sunday, 27 December 2020, 23:26 GMT
The patch is applied and tested. Works just fine and you now have 500k to work with. Enjoy.

Loading...