Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68989 - [gnome-session] 2 minutes delay at poweroff with systemd-247

Attached to Project: Arch Linux
Opened by Peter Weber (hoschi) - Tuesday, 15 December 2020, 17:41 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 30 December 2020, 07:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
Starting from systemd-247 when using GNOME, DBus gets restarted during shutdown or reboot. This leads to a 120 second delay during shutdown and a blinking cursor. You can only see that something hangs with hitting Ctrl+Alt+Del and/or Esc. This incline users into the bad decision to turn of the computer hard. I don't know how often systemd is currently syncing the disks and re-mounting during shutdown but this can lead to a data loss.


Additional info:
* package version(s): systemd 247.1-1 and a recent gnome-session
* config and/or log files etc.: see upstream
* link to upstream bug report, if any: https://gitlab.gnome.org/GNOME/gnome-session/-/issues/74

Steps to reproduce:
1.) Login into GNOME
2.) Restart or Shutdown

Workarounds:
Logout from GNOME and then restart or shutdown from a TTY.

Upstream fix is available:
https://gitlab.gnome.org/GNOME/gnome-session/-/merge_requests/55/diffs?commit_id=9de6e40f12e8878f524f8d429d85724c156a0517


Can we please apply the that patch from upstream and add it to gnome-session?
Thank you
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 30 December 2020, 07:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  gnome-session 3.38.0+14+g87d92fec-1
Comment by Strangiato (Strangiato) - Tuesday, 22 December 2020, 12:14 GMT
My Arch + Gnome hangs every time I try to reboot it.
Applying the fix for this annoying problem would be very appreciated.
Thanks.
Comment by Bario (barmadrid) - Monday, 28 December 2020, 04:21 GMT
Fixed in gnome-session 3.38.0+14+g87d92fec-1
Comment by Viktor Jägersküpper (viktorjk) - Monday, 28 December 2020, 10:20 GMT
This is a duplicate of  FS#68852 .
Comment by Peter Weber (hoschi) - Tuesday, 29 December 2020, 23:52 GMT
Seem to be fixed with "3.38.0+14+g87d92fec-1". Thanks!

Loading...