Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68907 - [vtk] missing dependency: unixodbc

Attached to Project: Arch Linux
Opened by simon (hiaselhans) - Wednesday, 09 December 2020, 11:59 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 09 December 2020, 15:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

vtk is missing a dependency: unixodbc

Additional info:
* package version(s) 8.2.0-17
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

pacman -S vtk
python
>>>import vtk

ImportError: libodbc.so.2: cannot open shared object file: No such file or directory
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 09 December 2020, 15:12 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Wednesday, 09 December 2020, 13:23 GMT
It's not missing, it's optional. If you import everything, you're probably going to need most/all of the optional deps.

Loading...