Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68905 - [light-locker] unable to unlock session after updating to light-locker 1.9.0-3

Attached to Project: Community Packages
Opened by Oleg (pekmop1024) - Wednesday, 09 December 2020, 11:05 GMT
Last edited by Maxime Gauduin (Alucryd) - Monday, 21 December 2020, 13:24 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 15
Private No

Details

Description:
Latest light-locker update 1.9.0-3 is broken.,
Additional info:
* light-locker 1.9.0-3

Steps to reproduce:
After entering password on lock screen it goes just to black screen instead of desktop. After killing light-locker process in console and switching back to vt7 there is unlocked session, though. Downgrading light-locker to 1.9.0-2 fixing this issue, so it seems to be localized in this changes: https://github.com/archlinux/svntogit-community/commit/f2f327b937416353702e29851201d0c24e91ed77

This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Monday, 21 December 2020, 13:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.9.0-4
Comment by Zero (attackzero) - Wednesday, 09 December 2020, 12:17 GMT
I am having the same issue. I ran light-locker with the --debug flag, and it is throwing errors about dbus (see attached log). I reported the issue upstream as well to the author of the pull request with these three commits (https://github.com/the-cavalry/light-locker/pull/153).
Comment by Paulo Marcos (Myghi63) - Wednesday, 09 December 2020, 18:11 GMT
I'm having the exact same problem, on both my desktop and my laptop. Running official arch linux, with manual installation and xfce4 + lightdm-gtk-greeter. Downgrading to light-locker-1.9.0-2 "fixed" the problem.
Comment by Craig Slusher (sleekslush) - Friday, 11 December 2020, 15:15 GMT
Yep, confirmed exact same issue here. If locking is urgent, and you just happen to be using xfce4, this is a temporary workaround:

$ sudo pacman -Rs light-locker
$ sudo pacman -S xflock4
$ xfconf-query -c xfce4-session -p /general/LockCommand -s "dm-tool lock"
$ xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/lock-screen-suspend-hibernate -s true
Comment by lesebas (lesebas) - Tuesday, 15 December 2020, 20:48 GMT
Yes same problem for me, ethier I have a black screen either I have the notification screen (this session is locked...etc).
Comment by Rafaël Kooi (Serus) - Monday, 21 December 2020, 13:13 GMT
Those commits were mine, and it seems an update to systemd/lightdm has broken my method of grabbing the systemd session.
I have committed a fix that works with pantheon and XFCE.

I also saw some complain about the problem with i3, I didn't test the fix for that WM, but I see no reason as to why it should break there.

This is the commit in question: https://github.com/the-cavalry/light-locker/pull/153/commits/8e03981e83fd03920e8e68145d0eb933dddb4c3c
Comment by Maxime Gauduin (Alucryd) - Monday, 21 December 2020, 13:23 GMT
Thanks, I backported the additional commit into the package.

Loading...