Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68868 - [vte3] fix long delay on exit regression

Attached to Project: Arch Linux
Opened by Felipe Contreras (felipec) - Sunday, 06 December 2020, 12:57 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 06 December 2020, 14:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since version 0.60 a regression was introduced that basically hangs terminals on exit.

See the upstream report:

https://gitlab.gnome.org/GNOME/vte/-/issues/204

It can be triggered sending any command to the background:

sleep 1d &
exit

For more than a year this regression has been ignored.

In order to minimize the hang, they introduced first a 5 second timeout, and then a 2 second timeout.

But there's absolutely no reason to hang for even 1 second, when we can return to the behavior of 0.59, and exit immediately.

Upstream clearly has no interest in fixing the problem as evidenced in issue 319 where they said: "What issue? Works just fine here in the vte test application: the terminal closes after a short [**two** second] delay."

The attached patch returns to the behavior of 0.59, and does not wait for some output that is never going to come.

The patch has been tested in gnome-terminal, xfce4-terminal, terminator, lxterminal, and tilix. In all of them the 2 second timeout goes away, and they exit immediately.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 06 December 2020, 14:19 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Sunday, 06 December 2020, 14:19 GMT
Arch, as a rule, doesn't override upstream behavior.

Loading...