Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#68863 - Intel-ucode causing system to hang on reboot

Attached to Project: Arch Linux
Opened by Brett Crisp (Sugarcrisp) - Sunday, 06 December 2020, 04:35 GMT
Last edited by Christian Hesse (eworm) - Wednesday, 21 April 2021, 12:25 GMT
Task Type Bug Report
Category Upstream Bugs
Status Assigned
Assigned To Christian Hesse (eworm)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 2
Private No


Intel-ucode causing system to hang on reboot

Additional info:
* package version(s) 20201110-1, 20201112-1 and 20201118-1
* 5.9.11-arch2-1
*asus K501U laptop

Steps to reproduce:
Ran into system hang on reboot with 20201118-1 installed. No error messages. Tried downgrading to 20201112-1 and 20201110-1, but still causing system to hang. Downgraded to 20200616-1. Rebooted multiple times and system boots fine.
This task depends upon

Comment by Daniel Appelt (daniel.appelt) - Saturday, 12 December 2020, 20:45 GMT
I see a corresponding problem:

* HP EliteBook 840 G3 with Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz
* Linux 5.9.13-arch1-1
* intel-ucode 2020118-1
* boot via EFISTUB

Powering up on AC most always works. If after normal poweroff from AC I try to power up on battery the system hangs on boot. In general, it then does not get past the UEFI splash message. In this case, I only seem to be able to boot again when on AC.
Booting on battery only seems to work if it was powered off from battery before, i.e. if I unplug the power after powering up on AC. This makes it really hard to use the laptop "on the road".

I have now downgraded to intel-ucode 20200616-1 too. So far, everything seems to be back to normal.

For reference, also check bug reports regarding power up issues upstream:
Comment by Tom Yang (istomyang) - Friday, 18 December 2020, 04:50 GMT
Intel Core i7-6500U
It's a upstream question, same issue in Debian and REHL.
You can try old version.
Comment by Michael (ZeroBeat) - Tuesday, 19 January 2021, 17:11 GMT Comment by Daniel Appelt (daniel.appelt) - Friday, 09 April 2021, 10:36 GMT
In my case, updating the BIOS of the laptop solved the problem. The latest BIOS for my HP is from Oct. 2020.